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Technological progress and globalisation offer tremendous opportunities for 

innovation, job creation, and growth. In turn, remote sensing is one of the rapidly 

growing areas of technological advancements, that can be defined as the technology 

of obtaining information about different objects, land surface, aquatic environment, 

various phenomena, or processes without making physical contact with them. This 

may include data collection from satellites, aerial images, unmanned aerial vehicles 

and others. Remote sensing is a crucial source of data for Earth Observation (EO), 

enabling gathering information on the physical, chemical, biological, and any other 

related data about the planet, that is necessary to monitor land, aquatic (seas, rivers, 

lakes) environment, and atmosphere. 

With its wide variety of areas of application, remote sensing has an increasing impact 

on different groups of society – from scientific communities to industry, public 

institutions, and day-to-day users. However, the lack of understanding of the 

technical characteristics of remotely sensed data and their suitability for analysis 

limits the capacity of EO. Therefore, driving and supporting the advancement 

requires people to obtain new skills in remote sensing and Geographical Information 

Systems (GIS). The synergistic use of EO and GIS techniques allows one to transform 

data into information, therefore, it could be one of the areas in environmental 

education that are of high interest to future employers and stakeholders. 

The project Aquatic Remote Sensing in Higher Education (Qredo) was aiming to 

address the gap in the preparation of remote sensing experts capable of using the 

advancements offered by EO. An essential aspect of Qredo was the identification of 

the need for aquatic remote sensing applications considering the requirements of 

potential employers in Lithuania. Further, an advanced course to improve the 

knowledge and skills in EO data application was organised, and, as a final 
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achievement of the project, the practical sessions’ manual on the Remote Sensing 

and GIS applications for the aquatic environment assessment was prepared.  

Aimed at supporting and contributing to the advancement of labour market-oriented 

skills in remote sensing and GIS, this manual covers in-depth knowledge about Earth 

Observation and its practical applications for the studies of the aquatic environment. 

The manual has been designed in a way to help students, graduates, and other 

interested parties reach a more extensive and deeper understanding of the synergist 

use of remote sensing and GIS and to gain more practical skills. This work represents 

one of the most relevant deliverables of the Qredo project and it is expected to support 

filling the gap between the supply of and demand for space/geospatial education and 

training, focusing on marine satellite data products from past and current EO 

missions.  

The manual is organized as follows: the chapter on the basics of remote sensing 

introduces the user to the different sensors for gathering remote sensing data on 

aquatic environment. An introductory chapter on ESA SNAP software includes basic 

information on how to navigate the software, providing the main steps for satellite 

data analysis. QGIS for remote sensing data analysis and visualisation chapter is 

dedicated to QGIS – the open-source GIS software, that can be used to process, 

analyse, and visualize data gathered from remote sensing and UAVs. The chapter 

will explain how to import different types of data from different remote sensing and 

GIS data sources, and how to apply various GIS tools and functions to process 

remote sensing data. The thematic chapters on water temperature, ice, flood 

detection, chlorophyll-a (chl-a) mapping, bathymetry, water transparency, and ship 

detection cover different fields of remote sensing applications for the assessment of 

the aquatic environment and consist of a short theoretical part, data acquisition, and 

practical cases studies. 

 

 

         Qredo Project Team 
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Backscattering – process, when the energy is reflected directly back at an active 

sensor after hitting a target. 

Coordinate reference system (CRS) – A coordinate-based local, regional, or global 

system used to locate geographical entities.  

Electromagnetic Spectrum – continuum of all electromagnetic waves arranged 

according to frequency and wavelength, encompassing phenomena such as radio 

waves, microwaves, infrared radiation, visible light, ultraviolet radiation, X-rays, and 

gamma rays. 

Earth Observation – collection of data about Earth's physical, chemical, and 

biological systems through remote sensing technologies, often involving satellites or 

aircrafts. 

Georeference – to link spatial data to its correct location. 

HELCOM – The Baltic Marine Environment Protection Commission – also known as 

the Helsinki Commission. 

In situ - the observation and / or measurement of events in its original place. In 

remote sensing commonly referring to data collected on the ground to validate data 

collected from airborne or spaceborne sensors. 

LiDAR - Light Detection and Ranging — is a remote sensing method used to 

examine the surface of the Earth. 

MERIS – The Medium Resolution Imaging Spectrometer (MERIS) was an instrument 

onboard the European Space Agency's Envisat satellite, aimed at monitoring ocean 

color, surface temperature, and atmospheric parameters. 

MODIS – Moderate Resolution Imaging Spectroradiometer (MODIS) is a key 

instrument aboard NASA's Terra and Aqua satellites, designed to collect data in 36 

spectral bands and provide comprehensive imaging across the Earth's surface for 

various environmental monitoring applications. 

NOAA - National Oceanic and Atmospheric Administration. 

Pixel – smallest unit of a digital image that can be displayed and represented on a 

digital display device. Pixel represents a square area on an image an is a measure of 

the sensor's ability to resolve (see) objects of different sizes.  

Swath – The area imaged on Earth’s surface by one pass of an aircraft or satellite. 

USGS – The United States Geological Survey. 

 



I. Basics of remote sensing  
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Remote sensing is the technique of obtaining information about objects or areas from 

a distance, often by using satellites or flying aircrafts. There are primarily two types 

of remote sensing sensors: passive and active (Figure I-1). Passive sensors rely on 

natural radiation, usually sunlight, to illuminate the target. Examples include optical 

cameras and infrared sensors. These sensors measure the reflected or emitted 

radiation from the target area and convert these measurements into useful data. 

Active sensors, on the other hand, generate their own energy to illuminate the 

target, as is the case with radar and LiDAR systems. These systems emit a pulse of 

energy and measure the time it takes for the pulse to return after hitting the target, 

thereby determining characteristics like distance, speed, and shape. 

 
Figure I-1. Passive sensors detecting energy when the naturally occurring energy is available, and 

Active sensors provide their own energy source for illumination (Credit: URSA Space). 

Satellite data is often made available from a variety of sources, such as governmental 

space agencies like NASA, ESA, and commercial providers. The data can be acquired 

from different types of orbits, including geostationary, sun-synchronous, and polar 

orbits, each offering unique vantage points and revisiting times. 

Some of the most common databases for open-source remote sensing data include: 

▪ USGS Earth Explorer: Provides access to an extensive archive of satellite and 

aerial imagery, including Landsat and Sentinel data. 

▪ NASA Earthdata: Offers a wide range of NASA's Earth observation data, 

including MODIS, ASTER, and airborne datasets. 

▪ Copernicus Open Access Hub: Source for Sentinel-1, Sentinel-2, and Sentinel-

3 data, focusing primarily on environmental monitoring. 

▪ Copernicus Data Space Ecosystem: A new service to better access and exploit 

the EU's Copernicus satellites data, including Sentinel-1, Sentinel-2, and 

Sentinel-3. 

▪ NOAA CLASS: The Comprehensive Large Array-data Stewardship System 

provides data from NOAA's operational and research satellites. 

▪ JAXA Global ALOS Portal: Offers PALSAR and optical data from the Advanced 

Land Observing Satellite (ALOS) missions of the Japan Aerospace Exploration 

Agency. 
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▪ GloVis: The Global Visualization Viewer is another USGS service, providing a 

simplified way to search for remote sensing data. 

▪ Australian Geoscience Data Cube: Focuses on providing satellite data specific 

to the Australian continent, including Landsat and other data types. 

▪ INPE Image Catalog: The Brazilian National Institute for Space Research offers 

datasets primarily focused on South America. 

▪ EUMETSAT Data Centre: Provides meteorological data from European 

geostationary satellites, like the Meteosat series. 

▪ Alaska Satellite Facility: Specializes in radar and SAR data, including data 

from missions like RADARSAT and UAVSAR. 

These databases offer various types of remote sensing data, with different spatial, 

spectral, and temporal resolutions, catering to a wide range of scientific research and 

applications. 

Key attributes of satellite data include spatial, temporal spectral, and radiometric 

resolutions. Spatial resolution refers to the size of a single pixel in ground units and 

can range from centimetres in high-resolution imaging systems to hundreds of 

meters in moderate to low-resolution systems. 

 

Figure I-2. High-resolution satellite images (Pléiades and WorldView-3), and moderate resolution 
satellite images (Sentinel-2 and Sentinel-3). Example of Nida village and harbour in the Curonian Spit 

(Lithuania). 
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Temporal resolution indicates how frequently a sensor revisits the same location, 

which can be from multiple times a day to once in several days, depending on the 

satellite's orbit. However, because of some degree of overlap in the imaging swaths of 

adjacent orbits for most satellites (e.g., Aqua and Terra) and the increase in this 

overlap with increasing latitude, some areas of the Earth tend to be re-imaged more 

frequently. Spectral resolution pertains to the number and width of specific 

wavelength bands that a sensor can record. For example, multi-spectral sensors 

capture data in a few wide bands, whereas hyperspectral sensors capture data in 

many narrow bands, offering more detailed information about the target. Radiometric 

characteristics describe the actual information content in an image. Every time an 

image is acquired by a sensor, its sensitivity to the magnitude of the electromagnetic 

energy determines the radiometric resolution. The radiometric resolution of an 

imaging system describes its ability to discriminate very slight differences in energy. 

The finer the radiometric resolution of a sensor, the more sensitive it is to detecting 

small differences in reflected or emitted energy. Imagery data are represented by 

positive digital numbers which vary from 0 to (one less than) a selected power of 2. 

This range corresponds to the number of bits used for coding numbers in binary 

format. Each bit records an exponent of power 2 (e.g., 1 bit = 21=2). The maximum 

number of brightness levels available depends on the number of bits used in 

representing the energy recorded. Thus, if a sensor used 8 bits to record the data, 

there would be 28=256 digital values available, ranging from 0 to 255. However, if 

only 4 bits were used, then only 24=16 values ranging from 0 to 15 would be available. 

The radiometric resolution would be much less. 

All sensors employed on satellites use electromagnetic radiation to view the Earth. 

The capability of particular sensors to measure certain properties and how well they 

can view through the atmosphere or penetrate clouds depends critically on which 

part of the electromagnetic spectrum they use. Figure I-3 shows regions of the 

electromagnetic spectrum that are of relevance to remote sensing and in particular 

the bands occupied by the four broad classes of satellite sensors used for viewing the 

Earth. Figure I-3 also shows how transmittance of the atmosphere varies with 

electromagnetic wavelength, which accounts for why sensors are only found in 

certain wavebands. For much of the electromagnetic spectrum the atmosphere is 

opaque and, therefore, unusable for remote sensing of the ocean. However, there are 

a number of atmosphere ‘‘window’’ regions where most of the radiation gets 

through, although it may be attenuated to some extent. One of these windows 

extends from the visible part of the spectrum (between 400nm and 700 nm, used by 

the human eye) into the near-infrared (IR). This is used by radiometers that observe 

sunlight reflected from the ground and the ocean. Between wavelengths of about 3.5 

mm and 13 mm are found a number of narrow windows exploited by IR radiometers. 

This is called the thermal IR part of the spectrum because much of the radiation has 

been emitted by surfaces according to their temperature. At much longer 

wavelengths, greater than a few millimetres, the atmosphere becomes almost 

completely transparent. This is referred to as the microwave part of the spectrum, 

normally differentiated spectrally in terms of frequency rather than wavelength. 

Because it is widely exploited for many technological aspects of modern civilization, 
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including radio and TV broadcasts, telecommunications, mobile telephony, certain 

parts have to be specially reserved for remote sensing and are allocated by 

international regulation. They are found as discrete narrow frequency bands within 

the broad regions for microwave radiometry and radars. Microwave radiometers are 

passive sensors, simply measuring the naturally ambient radiation that is emitted 

by the ocean, atmosphere, and land surfaces. Radars are active microwave devices 

which emit pulses and measure echoes from the sea surface, in order to gain 

information about some aspect of the surface. 

 

Figure I-3. Diagram of the electromagnetic spectrum and the regions of atmosphere “windows” 

exploited by typical remote sensing instruments. (Credit: NASA Science) 

Levels of satellite data generally refer to the stages of processing the raw data goes 

through before it is ready for analysis (Figure I-4). Level 0 data are the raw signals, 

Level 1 involves radiometric and geometric corrections, Level 2 data are derived 

geophysical variables, and Level 3 and 4 represent processed, gridded, and 

sometimes model-integrated datasets. These levels help standardize data for 

research and operational applications. 
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Figure I-4. Outline of data-processing tasks to convert raw satellite data into environmental variables 

(after Robinson, 2010). 

Optical data. 

The optical satellite sensors are passive. They take imagery in the visible or near-

visible portion of the electromagnetic spectrum, using the sun's radiation as it 

reflects off of our planet and atmosphere (Figure I-5).  

 

Figure I-5. Sentinel-2 acquiring the data and the electromagnetic spectrum (Credit: Mini Physics 2006). 

The basic principle of optical remote sensing is straightforward. The light measured 

by an optical sensor pointing towards the Earth surface comes originally from the 

Sun. Some photons of light emitted by the Sun, with energies that place them in the 

visible part of the spectrum, enter the surface where they are either absorbed or 

scattered, depending on the objects. Those of the scattered photons are quantified 

by a satellite optical sensor, which measures the amounts of different wavelengths 

of light reaching it. In practice, it is the spectral radiance at the top of the atmosphere 

that is measured from a satellite. This consists of light reflected by the atmosphere 

and the land or water surface. The retrieval of useful quantities from top-of 
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atmosphere measurements is a challenging task, requiring careful separation of 

atmospheric scattering and surface reflection. 

In aquatic environment, direct Sun light and scattered sky light, that penetrate the 

water surface, may be absorbed or scattered by the water molecules, or by the 

various suspended and dissolved materials present in the water (Figure I-6). In 

shallow, clear waters, a significant part of the light from the sun may reach the 

bottom and be reflected from it. Some of the scattered and reflected photons 

eventually find their way to the remote sensor. Remote sensing involves analyses of 

the variations in magnitude and spectral quality of the water-leaving radiation to 

derive quantitative information on the type of substances present in the water and 

their concentrations. Clearly, this has to be based on a sound understanding of the 

optical properties of the medium, and of the optical processes in the medium. 

 

Figure I-6. Factors that influence upwelling light leaving the sea surface. (a) upward scattering by 
inorganic suspended material; (b) upward scattering from water molecules; (c) absorption by the yellow-
substances component; (d) reflection off the bottom; and (e) upward scattering from the phytoplankton 

component. Note that absorption by any of these components or by the bottom will serve to decrease the 
water-leaving signal. Light from the sun may be scattered by atmospheric constituents before it reaches 
the sea surface. Similarly, light leaving the water may be scattered away from, or towards the remote 

sensor by the atmosphere (Credits: IOCCG, 2000). 

A serious disadvantage of remote sensing from Earth observation satellites is the 

atmosphere. The greater part of the measurement of visible wavelengths of light made 

looking down from a satellite orbit comes from light scattered by the atmosphere into 

the field of view of the sensor, which may contribute more than 90% of total measured 

radiance. The atmosphere is opaque to electromagnetic radiation at many 

wavelengths, and there are only certain wavelength windows through which radiation 

may be fully or partially transmitted. Atmospheric gas molecules themselves may 

absorb or scatter radiation, and, in addition, water vapour, aerosols, and suspended 
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particles of dust will do the same. If water droplets are present in the form of clouds, 

they may completely change the transmission properties of the atmosphere. A major 

task for the analysis of satellite data is to take into account the effect of the 

atmosphere and perform the atmospheric correction. Otherwise, it involves 

estimation of the effect that the atmosphere has had on measured electromagnetic 

radiation, between leaving the Earth and reaching the sensor. 

Environmental optical satellite missions are designed to acquire information on the 

biogeochemical status of Earth’s ecosystems. No instruments currently exist that 

can directly measure biogeochemical variables from space. Because remote sensing 

devices record physical electromagnetic emanations from some combination of 

organic and/or inorganic matter, comprising the biosphere, these electromagnetic 

data must be converted through appropriate multidisciplinary modelling activities 

into inferred estimates of the environmental variables (Figure I-7). Therefore, 

development of biophysical models and algorithms is essential to remote sensing. 

Most satellite data models and algorithms require knowledge of the optical properties 

of the organic and inorganic biospheric matter admixture indigenous to the local 

environmental target or scene. Invariably, such admixtures are temporally and 

spatially variable. Consequently, the development of general or universal 

environmental parameter-extraction algorithms for remotely sensed data on a global 

scale is highly unlikely. Extraction algorithms, therefore, are constrained to be local 

in application (particularly, if such algorithms are based on regressions between 

ground-measured environmental variables and satellite-recorded values of radiation 

at some wavelength or group of mathematically entwined radiations from several 

wavelengths). It is possible to generate theoretical models that possess degrees of 

acceptable rigor and robustness. However, application of these models invariably 

requires precise numerical values of the optical properties of the indigenous 

ecosystem membership and/or the rates of photobiological and photochemical 

productivity as a function of wavelength (action spectra) pertinent to the ecosystem 

under study. Calibration and validation of existing and developing models and 

algorithms remain a crucial step for the retrieval of accurate information from the 

optical satellite data. 

 

Figure I-7. Generic optical satellite image processing chain. Pre-processing is the correction of satellite 
image data containing the distortion due to the properties of the imaging system and imaging conditions. 

This type of distortion is corrected in this step and mainly include radiometric correction, geometric 
correction, geo-referencing and resampling. The atmospheric correction and cloud masking is referred to 

removal of any distortions that are caused by atmosphere, could or cloud shadows. 

In general, the models and algorithms can be categorised as: 

▪ Image Classification and Segmentation Algorithms: 

o Supervised Classification: Algorithms that use training data to classify 

pixels or regions into predefined classes (e.g., land cover types). 
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o Unsupervised Classification: Clustering algorithms that group pixels 

based on similarity without predefined classes. 

o Semantic Segmentation: Algorithms that assign semantic labels to each 

pixel to distinguish different object categories within the image. 

o Instance Segmentation: Identifying and delineating individual objects 

or instances within a scene. 

▪ Radiometric indices - quantitative measures of features that are obtained by 

combining several spectral bands, features that are not otherwise obvious if 

using only one band: 

o Normalized Difference Vegetation Index (NDVI): Calculates vegetation 

health and density by comparing the reflectance in the near-infrared 

and red bands. 

o Leaf Area Index (LAI) Estimation: Estimates the amount of foliage in a 

vegetated area. 

o Vegetation Indices: Various indices (e.g., EVI, SAVI) for assessing 

vegetation characteristics and health. 

o Water Indices: Calculating water indices like the Normalized Difference 

Water Index (NDWI) to identify water bodies. 

▪ Semi-analytical algorithms are a class of algorithms used in remote sensing, 

particularly in the field of water quality and aquatic ecosystem monitoring. 

These algorithms are designed to estimate various water quality parameters, 

such as concentrations of chlorophyll-a, suspended sediments, and other 

optically active substances in water bodies, based on the analysis of spectral 

reflectance or radiance data obtained from optical remote sensing sensors, 

such as those on satellite or airborne platforms. The term "semi-analytical" is 

used because these algorithms incorporate both analytical and empirical 

components in their modelling approach. 

▪ Machine Learning and Deep Learning Algorithms: various machine learning 

and deep learning techniques, including neural networks (NNs) - a full 

spectrum version using a set of neural networks which are trained on 

simulated top-of-atmosphere reflectance, convolutional neural networks 

(CNNs), are used for tasks such as image classification, object detection, and 

semantic segmentation. 

The decision on the most appropriate algorithm or model for remote sensing of 

aquatic environment, in order to prevent the failure and inaccurate results, relies on 

the initial step, determining the type of water masses. Water masses are commonly 

classified into one of two types: Case 1 or Case 2. A bipartite classification scheme 

was introduced by Morel and Prieur (1977) and refined later by Gordon and Morel 

(1983). By definition, Case 1 waters are those waters in which phytoplankton (with 

their accompanying and co-varying retinue of material of biological origin) are the 

principal agents responsible for variations in optical properties of the water. On the 

other hand, Case 2 waters are influenced not just by phytoplankton and related 

particles, but also by other substances, that vary independently of phytoplankton, 

notably inorganic particles in suspension and yellow substances. 
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Figure I-8. Cyanobacteria bloom in the Baltic Sea. True colour Sentinel-3 image and spatial distribution 
of chlorophyll-a concentration after the application of retrieval algorithm. 

Applications: Optical satellite images, which are captured using sensors that 

detect visible light, are valuable for a wide range of applications across various fields. 

Each application itself has specific demands, for spectral resolution, spatial 

resolution, and temporal resolution. Optical satellite imagery is a versatile tool that 

continues to evolve with advances in technology, enabling a wide range of 

applications for environmental monitoring, disaster management, resource 

management. Key applications of optical satellite imagery are: 

▪ Environmental Monitoring: 

o Water Quality Assessment: Identifying changes in water bodies such as 

rivers, lakes, and oceans, including pollution and algal blooms, 

suspended sediments, coloured dissolved organic matter, water 

transparency and photic zone, aquatic vegetation (Figure I-9). 

o Land Cover and Land Use Analysis: Optical satellite images help track 

changes in land cover and land use, including deforestation, urban 

expansion, and agricultural trends. 

o Vegetation Health Assessment: Monitoring vegetation health and 

detecting issues like forest fires, pest infestations, and drought stress. 

▪ Agriculture: 

o Crop Monitoring: Assessing crop health, growth, and yield estimation. 

o Precision Farming: Optimizing resource allocation, including irrigation 

and fertilization, for efficient agricultural practices. 

o Crop Disease Detection: Identifying diseases and pests affecting crops. 

▪ Disaster Management: 

o Natural Disaster Assessment: Rapidly assessing the extent of damage 

caused by events like hurricanes, earthquakes, floods, and wildfires. 

o Search and Rescue: Aiding in the search for missing persons in 

disaster-stricken areas. 

▪ Urban Planning and Development: 

o Urban Growth Analysis: Monitoring urban expansion and 

infrastructure development. 
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o Traffic and Transportation Planning: Analyzing traffic patterns and 

optimizing transportation systems. 

▪ Forestry and Natural Resource Management: 

o Forest Inventory: Estimating timber volumes and monitoring illegal 

logging. 

o Wildlife Conservation: Studying wildlife habitats and migration 

patterns. 

▪ Geology and Mining: 

o Geological Mapping: Identifying geological features and potential 

mineral resources. 

o Mine Monitoring: Monitoring mining operations and environmental 

impacts. 

▪ Climate Change Studies: 

o Glacier and Ice Cap Monitoring: Tracking changes in ice cover and sea-

level rise. 

o Snow Cover Analysis: Assessing snowpack levels and snowmelt 

patterns. 

▪ Natural Resource Management: 

o Wetland and Coastal Zone Mapping: Monitoring changes in wetlands 

and coastal areas. 

o Water Resource Management: Assessing water levels, quality, and 

usage. 

▪ Weather Forecasting: 

o Cloud Cover Analysis: Monitoring cloud patterns for weather 

prediction. 

o Hurricane and Cyclone Tracking: Tracking the movement and intensity 

of storms. 

 

Figure I-9. Suspended matter distribution in the coastal waters of the Baltic Sea retrieved from OLCI 
Sentinel-3 and MSI Sentinel-2 data. The increase of suspended matter is caused by the intensive 

renovation of Liepaja port in Latvia during February 2018. 
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Thermal Infrared Remote Sensing data  

All bodies having temperatures higher than the absolute zero (-273.15 °C) emit 

thermal radiation, the strength of which depends on the body’s surface temperature. 

The higher is the temperature, the greater the radiant energy of the body. Therefore, 

the determination of the SST from space is based on measuring the thermal radiation 

energy coming from the sea surface. The instruments, called radiometers, determine 

the radiant energy flux within distinct intervals of the electromagnetic spectrum. 

Clear sky conditions are required for the derivation of SST from IR measurements as 

the IR radiation does not propagate unhindered through clouds, and, even in cloud-

free conditions, the constituents of the atmosphere such as CO2, H2O, CH4, NO2 and 

aerosols absorb some of the radiation emitted by the sea before it reaches the detector 

in space, and at the same time they re-emit radiation (Minnett et al., 2019). To 

overcome the issue of atmospheric absorption, the spectral intervals (wavelengths), 

therefore, are chosen at the locations where the sea emits a measurable amount of 

radiant energy, and where the atmosphere is sufficiently transparent to allow the 

energy to propagate to the spacecraft (Minnett, 2001). This is the so-called 

atmospheric window – a wavelength of energy that is most easily transmitted to 

Earth. For this reason, IR radiometry of the sea surface is restricted to two spectral 

windows in the approximate ranges 3.5–4.1 μm and 10.0–12.5 μm that are used for 

IR sensing of the ocean; the microwave measurements are made at frequencies of 6–

12 GHz. However, one must note, that none of the atmospheric windows is 

completely transparent, therefore, atmospheric corrections for cloud-free pixels are 

still required. In addition, the effect of reflected sunlight shall also be considered, as 

it has a different effect for different spectral windows. Though the 3.5–4.1 μm 

channel is more sensitive to SST changes, it is primarily used only for night-time 

measurements as the reflected sunlight can create strong errors; while 10-12.5 μm 

channel can be used both, day, and night. 

Passive Microwave Remote Sensing of SST  

As was discussed in the previous chapter, infrared radiometers are mainly used for 

the sea surface temperature estimates from space, however, it is only possible under 

cloud-free conditions. Thermal radiation at microwave frequencies, however, is much 

less likely to be blocked by clouds. Therefore, spaceborne passive microwave (PMW) 

imagers can use this radiation for SST estimates under a much wider range of 

atmospheric conditions than infrared radiometers can (Langille, Buckley, 2002) and 

can be a good alternative to acquire satellite SST data. Nevertheless, a lower signal 

strength of the radiation curve in the microwave region makes the accuracy and 

resolution of passive microwave SST poorer as compared to IR SST. Another 

difference between IR and PMW SST is measurement depth, i.e., at the wavelengths 

where PMW operates the penetration depth is 1-3mm (SSTsubskin) while IR SST 

measurements represent only approximately 10-20 m μm within the ocean skin layer 

(more information on SST in chapter IV). 

Passive microwave SST measurements are primarily made at channels near 6-7 GHz 

and/or 11 GHz with a water vapour correction enabled by observations at 21 GHz. 

But even though radiation at longer wavelengths is unaffected by clouds, wind-
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generated roughness at the ocean surface and precipitation influences passive 

microwave signal return. Land (also ice marginal zone) contamination is also an issue 

with microwave measurements, as within 50-100 km of land microwave 

measurements are affected by emissions from land, therefore, microwave SST 

observations are typically not produced within 50-100 km of land (Cummings, 2011). 

Due to the aforementioned limitations (mainly land contamination and coarse 

resolution) of PMW, SST measurements from IR radiometers are more suitable for 

the monitoring of landlocked water bodies that are smaller in size (e.g., the Baltic 

Sea and its coastal lagoons). Nevertheless, PMW SST is a valuable source for the 

global ocean coverage to be observed at daily frequencies (Figure I-10). 

 

Figure I-10. a) SST of the Global Ocean derived from IR measurements (top image) and a microwave-
derived SST (bottom image) ©NASA JPL/PO.DAAC; b) SST of the Baltic Sea: derived from MODIS IR 

measurements (top image) and from microwave AMSR-2 measurements (bottom) © 

Passive microwave instruments used for deriving SST include Advanced Microwave 

Scanning Radiometer – Earth Observing System (AMSR-E) and Advanced Microwave 

Radiometer 2 (AMSR2) on the NASA EOS Aqua satellite, Tropical Rainfall Measuring 

Mission (TRMM) Microwave Imager (TMI) and others. Currently, a new radiometer of 

ESA for the Copernicus Expansion program of the European Union, the Copernicus 

Imaging Microwave Radiometer (CIMR), is in the preparatory phase, with an 

estimated launch date in the 2025+ time frame. It is designed to observe the ocean 

and sea ice and more particularly the Arctic environment. Amongst other 

parameters, such as the Sea-Surface Salinity (SSS) and Sea Ice Concentration (SIC), 

CIMR will also be used for deriving Sea Surface Temperature data (more information 

at eoportal.org). 
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Synthetic Aperture Radar 

Synthetic Aperture Radar (SAR) represents a paradigm shift in remote sensing 

technology by employing active data collection, where the sensor generates its own 

energy and measures the energy reflected back after interacting with the Earth. 

Unlike interpreting optical imagery, which is analogous to analysing a photograph, 

SAR data interpretation requires a nuanced approach as the signal responds to 

surface characteristics like structure and moisture. 

 

Figure I-11. Geometry of observations used to form the synthetic aperture for target P at along-track 
position x=0 (Credit: NASA SAR Handbook). 

SAR Platforms: The availability of consistent SAR datasets became more 

widespread with the launch and open data policy of ESA's Sentinel-1a in 2014. Other 

prominent SAR platforms contributing to the availability of varied datasets include 

ERS-1 and 2, ENVISAT, ALOS PALSAR, TerraSAR-X, COSMO-SkyMed, and 

RADARSAT-2. Main SAR data providers are: European Space Agency (ESA), National 

Aeronautics and Space Administration (NASA) Canadian Space Agency (CSA), 

Deutsches Zentrum für Luft- und Raumfahrt e.V. (DLR).  

Different Wavelengths: Wavelength is a pivotal feature in SAR technology, 

dictating how the radar signal interacts with the surface and the depth of signal 

penetration into a medium. The different wavelengths, often referred to as bands like 

X, C, L, and P, have distinct applications ranging from high-resolution urban 

monitoring to airport surveillance. For instance, the X band, with a frequency of 8–

12 GHz and wavelength of 3.8–2.4 cm, is utilized for high-resolution SAR 

applications, such as urban monitoring (Table I-1). 
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Table I-1. Different wavelengths / bands of SAR and their applications. 

Band Frequency Wavelength Application 

Ka 27–40 GHz 1.1–0.8 cm Rarely used for SAR (airport surveillance) 

K 18–27 GHz 1.7–1.1 cm rarely used (H2O absorption) 

Ku 12–18 GHz 2.4–1.7 cm rarely used for SAR (satellite altimetry) 

X 8–12 GHz 3.8–2.4 cm High resolution SAR (urban monitoring, ice and 
snow, little penetration into vegetation cover; 
fast coherence decay in vegetated areas) 

C 4–8 GHz 7.5–3.8 cm SAR Workhorse (global mapping; change 

detection; monitoring of areas with low to 
moderate penetration; higher coherence); ice, 
ocean maritime navigation 

S 2–4 GHz 15–7.5 cm Little but increasing use for SAR-based Earth 
observation; agriculture monitoring (NISAR will 
carry an S-band channel; expends C-band 
applications to higher vegetation density) 

L 1–2 GHz 30–15 cm Medium resolution SAR (geophysical 
monitoring; biomass and vegetation mapping; 
high penetration, InSAR) 

P 0.3–1 GHz 100–30 cm Biomass. First p-band spaceborne SAR will be 
launched ~2024; vegetation mapping and 
assessment. Experimental SAR. 

SAR’s ability to penetrate clouds gives it a distinct advantage over optical data, 

expanding its application in diverse fields. The uses for SAR data are extensive and 

include airport surveillance, aiding in maritime navigation, monitoring agriculture, 

mapping biomass and vegetation, determining sea surface temperature, and 

analyzing wave patterns. The versatility of SAR data makes it an invaluable tool in 

various scientific, environmental, and security applications. More information on 

SAR can be also found in Chapter V. 

Unmanned Aerial Vehicles (UAVs)  

UAVs play a pivotal role across a spectrum of remote sensing applications. They are 

instrumental in acquiring detailed local measurements, crucial for microclimate 

studies and soil analysis, and offer invaluable insights into forest production, aiding 

in sustainable management and conservation efforts. Additionally, UAVs are 

indispensable for monitoring the health of ecosystems, crops, and urban areas, 

facilitating early detection of diseases, pest infestations, and environmental stress. 

They are also employed for species identification, contributing to biodiversity studies 
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and ecological conservation. Beyond natural environments, UAVs are extensively 

used for infrastructure inspection and disaster assessment, ensuring structural 

integrity of buildings, and providing rapid evaluations of areas affected by natural 

calamities. 

 

Figure I-12. A single drone-captured image on the right with a detailed, cohesive map formed by 
mosaicking multiple images on the left, illustrating how UAVs enhance spatial coverage and detail in 

remote sensing applications. 

Equipment: Both piloted and unmanned aircraft equipped with advanced sensors 

such as optical cameras, multispectral imagers, thermal cameras, and LiDAR 

sensors are employed in remote sensing. This diverse array of equipment allows 

UAVs to capture multifaceted data, catering to the specific requirements of various 

applications. 

Point Clouds and 3D Structures: Utilizing sensors such as LiDAR, UAVs can 

generate detailed point clouds—sets of data points in space representing the external 

surface of objects. These point clouds are instrumental in creating accurate 3D 

models of structures, landscapes, and vegetation, offering a comprehensive spatial 

representation of the surveyed area. 

Software and Data Acquisition: Data gathered by UAVs is processed using 

specialized software that uses Structure From Motion (SFM) algorithms to mosaic 

images into maps, allowing users to analyse, visualize, and interpret the collected 

data. Some examples of the software would be Pix4D or DroneDeploy. Practical 

acquisition of data involves careful planning, ensuring optimal flight paths, and 

adhering to legal and safety regulations.  



24 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

24 

 

II.  Introduction to ESA SNAP 
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ESA’s Sentinel Application Platform (SNAP) is an open-source and free to use set of 
toolboxes ideal for the exploitation of Earth Observation data. In this manual, only 
the basic information on how to navigate ESA SNAP software will be provided with 
some useful steps and tips for satellite data analysis. 

Downloading SNAP: You can download SNAP from ESA’s Science Toolbox 

Exploitation Platform:  https://step.esa.int/main/download/snap-download/ 

There are three different installers to choose (Windows 64-Bit, Mac OS X and Unix 

,4-Bit), select one according to your system:  Sentinel Toolboxes > *Installer you 

have chosen > Main Download (Figure II-1). 

 

Figure II-1. SNAP installation window (from SNAP Download – STEP (esa.int)) 

Then follow the steps of ESA SNAP installation wizard to complete the installation.  

SNAP interface: ESA SNAP interface (Figure II-2) is user friendly, enabling one to 

process and analysis the Earth observation data in a simple steps. 

 

Figure II-2. SNAP interface. 

https://step.esa.int/main/download/snap-download/
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General tools and steps of satellite data processing 

Importing data: There are many input data formats that SNAP supports, therefore, 

here only few examples of loading data will be demonstrated. To load the data into 

SNAP one may choose from several options, e.g., File > Import > *file type of your 

choice* or File > Open Product… (Figure II-3). 

 

Figure II-3. Example of loading data into SNAP. 

This allows user to import satellite data or other formats of data to be processed via 

SNAP software.  

After importing satellite data (e.g., File > Import > Generic Formats > NetCDF) the 

band of interest must be selected (Figure II-4), then colour scale (Figure II-5 and 

Figure II-6), reprojection (Figure II-7) and/or other modifications can be applied.  

Selecting bands: In the Product Explorer window click on the box to expand 

selections and choose the band to work with. In the provided example, 

sea_surface_temperature (SST) band is chosen. 

 

Figure II-4. Selecting band to be displayed in SNAP. 
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Adding colour scale: In the Colour Manipulation window press on the Import 

colour palette from text file icon and choose the preferred colour palette (Figure 

II-5). 

 

Figure II-5. Importing colour palette. 

In the provided example spectrum_large.cpd was chosen to best reflect the SST 

values. After importing the colour palette, the spectrum range can be modified using 

Basic, Sliders or Table editor options. 

 

Figure II-6. Adjusting colours of the displayed image. 

Using Sliders editor one can manually adjust the range of the histogram; using Basic 

option the Min and Max values of the range can be modified; using Table option a 

distinct value can be assigned to each colour. 

Reprojecting the image: Reprojecting – i.e., transforming an image from one 

coordinate system to another is sometimes necessary to align different images or 

data sets that have been acquired with different sensors or platforms, also it is used 

to adjust for geometric distortions or to change the resolution or the projection of an 

image. The steps are the following: Raster > Geometric > Reprojection > *the 

coordinate system of your preferences* 
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Figure II-7. Steps of reprojecting the image. 

Before reprojecting, check if the Source Product name is the one you want to work 

with. Deselecting Save as: BEAM-DIMAP (or other file formats) is recommended as 

it makes the tool run faster. Unless you want the file to be physically saved to the 

file system in a specific format, keep it selected. In the Reprojection Parameters 

section one can choose the Coordinate Reference System (CRS) (from “Custom 

CRS" – creating yourself; "Predefined CRS" – selecting one; or - "Use CRS of file" – 

using coordinate system from the file). In the example of Figure II-8, a WGS 84 / 

UTM zone 34N was chosen as the area of interest – Lithuanian Baltic Sea, is 

attributed to this zone.  

In the Output Settings section one can deselect Preserve resolution and manually 

set the parameters, such as Pixel size and others. After successful reprojection of the 

data, a new file in the Product Explorer will appear, which will have the same file 

name as the original file, only with an ending “_reprojected”. 

 

Figure II-8. An example of image before and after reprojecting. 

Importing vector data: Once the raster data is imported, user can import 

additional data, e.g., vector data can be inserted, following steps: File > Import > 

Vector data > *format of your preference*. Imported vector data can be used for 
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the further analysis of the data. One can import profile lines, polygons, points with 

coordinates etc., in the format of ESRI Shapefiles (*in the same coordinate reference 

system as the raster product), CSV files and others. Vectors can also be used as 

masks in the Mask manager and for lots of other purposes. 

In the Analysis tools there are many useful options, such as making correlative, 

histogram, profile, scatter, spectrum plots or calculating statistics of the selected 

bands. Correlative plots Analysis > Correlative Plot might be useful, e.g., for 

investigating how the satellite data and in situ data match. Profile plots enable to 

display profile plots for selected band. An example in Figure II-9 demonstrates a 

profile plot generated from an imported shapefile (File > Import > Vector data > 

ESRI Shapefile > *name of your file*) and one of the possible ways to analyse the 

data (Analysis > Profile Plot). 

 

Figure II-9. Generating a profile plot. 

The profile plot can also be edited (name of the axis, title, colours etc.) using Edit 

chart properties tool and then it can be saved as an image (Figure II-10) 

 

Figure II-10. Editing/saving a profile plot. 

Before importing CSV file, make sure that it has a header line with column names 

(e.g., “lat” or “latitude” – for latitude, “DateTime”, in situ values, etc.). When the file 

can be imported following the steps: File > Import > Vector data > Vector from 

CSV > *name of your file* > Use target CRS > Leave imported data unchanged. 
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Selecting the box Use ROI mask(s) lets one choose the file to be displayed. In figure 

10 an example of statistics, calculated for Sea Surface Temperature (SST) pixels at 

the given coordinates (CSV file “coord”) is presented. As can be seen, pixel A is located 

at the land, therefore, statistics for SST values are only available for pixels at the 

locations B and C (Figure II-11). The statistics can be displayed on screen or can be 

exported as CSV file via selecting this icon . 

 

Figure II-11. An example of analysis for imported CSV files. 

Masks: Masks can be useful for masking certain image pixels for the display or for 

image analysis. They can be generated from geometries (e.g., line, polygon), flags, 

and band math expression; also, different combinations of masks are available. 

Masks can be applied View > Tool Windows > Mask Manager or choosing this  

icon. When new masks can be created, or existing ones applied (Figure II-12). Via 

pressing this icon  masks can also be transferred to other products. 

 

Figure II-12. An example of applying masks. 
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Exporting data: The steps of exporting data are similar to the steps of importing 

data. Note: prior exporting, the data file, from which data is going to be exported, 

needs to be selected (highlighted). 

Steps for exporting the data: File > Export > *file type of your choice*. The Figure 

II-13 demonstrates the option to export View and Colour Legend as image. 

 

Figure II-13. An example of exporting image and colour legend. 

Choosing option File > Export > GeoTIFF > Export Product lets one export product 

as it is, however, sometimes satellite data files can be quite large, also not all bands 

are needed for further analysis, in that case one may choose to modify the Subset 

he wants to export. Spatial Subsets enables modifying the scene, Band Subset lets 

one choose the bands to be exported. As Figure II-14 demonstrates, choosing only 

sst4, longitude and latitude bands instead of all available bands reduced the 

Estimated raw storage size from 60.3M to 26.3M.  

 

Figure II-14. Exporting Product Subset. 

Masks can be exported by pressing a right mouse click on the image and choosing 

Export Mask Pixels > *mask to be exported* > Copy to Clipboard / Write to File 

or File > Export > Other > Export Mask Pixels (Figure II-15). 
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Figure II-15. Exporting Masks. 

Band Maths: The Band Maths Expression Editor provides a convenient way to 

construct maths expressions from various data sources, such as bands, tie-point 

grids and flag values. E.g., one can calculate a difference between the same band in 

two different products (note: to use the Band Maths they must be compatible, i.e., 

have the same width and height), create new bands, etc. The example in Figure II-16 

demonstrates how one can create a new band containing sea surface temperature 

information in degrees Celsius, instead of Kelvin degrees (as was in the original 

satellite image), following the steps: Raster > Band Maths > Edit Expression. Then 

from the sea_surface_temperature band (in Kelvins), 273.15 are subtracted, 

converting it to degrees Celsius. A new band will appear in the product bands. 

 

Figure II-16. An example of creating Band Maths. 

Pin Tools: A pin is a marker for a certain geographical position within a geo-

referenced image. You can find them in the toolbar section  - Pin Placing Tool;  

- Pin Manager, or in View > Tool Windows.  Pins can be useful for displaying the 

values of a pixel at the location the pin is placed.  After placing pins, use Pin Manager 

to display the values. To select the band values to be displayed, select Filter pixel 

data to be displayed in table icon  and then check the necessary boxes (Figure 

II-17). Pins can also be imported/exported from/to XML or text files and can be 

transferred to other products. 
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Figure II-17. Working with Pins. 

SAR image processing workflow 

Image Sub-setting/cropping: Satellite data files are very large; thus, their 

processing requires a lot of computing power. All subsequent SAR image processing 

steps will be time-consuming or potentially unsuccessful if sufficient resources are 

unavailable. To overcome this limitation one possible solution would be to first crop 

the image and focus solely on the desired location. To achieve this: 

1. Open one band of the chosen satellite image by pressing a “+” sign next to 

your uploaded file in the Product Explorer window. Then extend the Bands 

folder (“+”) and with the left mouse button double-click one band of your 

choice. An image should appear on the right side of the SNAP interface. 

2. Zoom in to the targeted area and clip the image (Figure II-18): 

2.1. Press the right mouse click on the image and choose Spatial subset 

from view. 

2.2. Clarify the bounding box (by moving the bounding box edges in the 

preview or by entering the starting and ending coordinates) and clip by 

pressing OK in the dialogue window. 

 

NOTE: Data providers process and provide data at different levels. 

This workflow is focused on Level 1 Ground Range Detected 

(GRD) data acquired from Sentinel-1 satellite. 
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Figure II-18. Specifying product subset. 

Now you can close the large SAR image by right-clicking it and choosing Close 

Product. If a window pops up asking if you want to save this file, then choose No. 

Application of Orbit File: Next, we will use the orbit update function, which is a 

process that automatically updates and corrects information about the satellite's 

position and speed. This is important because small variations in the satellite's orbit 

can introduce errors in the radar images it captures. By regularly collecting tracking 

data and incorporating it into the processing pipeline, we ensure that the radar 

images are accurately aligned with geographical coordinates. This helps to produce 

high-quality images that can be used for precise mapping and other applications that 

rely on accurate location information.  

SAR product metadata initially contains inaccurate orbit state vectors. It takes 

several days to determine the precise orbit of the satellite, and this information 

becomes available days to weeks after the product generation. The orbit update 

function in SNAP software automatically downloads and updates the orbit state 

vectors for each SAR scene, providing accurate satellite position and velocity 

information. To do this, in the upper menu bar choose Radar > Apply orbit file. In 

the popped-up window, you will see two tabs of settings (Figure II-19), make sure 

that in: (1) I/O Parameters tab: the source file is selected using your subset file, 

also, select the location where to save the intermediate files; (2) Processing 

Parameters tab: if you are using Sentinel-1 image, leave the setting as it is, otherwise 

chose the appropriate parameter from the Orbit State Vectors drop-down list. In 

case you are processing a very recent image, the Orbit State Vectors might not be 

yet available, thus check-mark the box that does not allow this tool to fail in case the 

orbit file is not found. 
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Figure II-19. Application of Orbit file. 

After this step, you will find a new layer in the Product Explorer window. 

Calibration: Next, we need to undergo a calibration procedure in which the digital 

pixel values are transformed into radiometrically calibrated radar backscatter values. 

Radiometric calibration is necessary to compare SAR images obtained with different 

sensors or obtained from the same sensor at different times, in different modes, or 

processed by different algorithms. Without radiometric calibration, the radar signal 

variations can lead to differences in brightness and contrast in the SAR images, 

making accurate comparison and interpretation challenging. To calibrate your SAR 

image:  

1. In the upper menu bar choose Radar, then select Radiometric and then the 

Calibrate function (Figure II-20). 

 

Figure II-20. Image calibration steps. 

2. In the pop-up window you will again see two tabs: 

2.1. I/O Parameters: as before, make sure that your orbit-applied subset 

layer and desired saving locations are specified.  

2.2. Processing Parameters: make sure that the sigma0 (backscatter 

coefficient) band is selected for the output. Click Run to execute. 
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After running this tool, in the Product Explorer section on the left of your screen, 

you will find a new layer (Figure II-21), which has your new calibrated bands of radar 

backscatter.  

 

Figure II-21. New layer. 

Speckle filtering (optional step): A speckle is a form of granular noise caused 

by the coherent nature of SAR imaging. It manifests as random variations in 

brightness and texture, creating a grainy appearance in the images. Speckle filtering 

is a technique used in SAR image processing to reduce this unwanted noise while 

preserving the important details and structures, i.e., the image's overall quality. 

Various speckle filtering methods exist, each with its own strengths and weaknesses. 

The choice of speckle filtering method depends on factors such as the desired level 

of noise reduction, preservation of image details, and computational efficiency. It's 

important to strike a balance between reducing the speckle noise and retaining the 

essential information in the SAR image to ensure accurate interpretation and 

analysis of the data. 

If you choose to apply the speckle filtering in the SAR image processing workflow, it 

is important to apply it before the other steps of image processing so that it does not 

transfer to them. The comparison of different filtering methods available on SNAP 

can be found in Jagtap and Shafiyoddin (2021) paper. To perform this step in SNAP 

software: 

1. In the upper menu bar choose Radar > Speckle filtering > Single Product 

Speckle Filter function (Figure II-22). 

 

Figure II-22. Steps of Speckle filtering. 

2. In the popped-up window you will see two tabs of settings, make sure that in: 
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2.3. I/O Parameters tab: the source file is selected using your calibrated 

subset file, also select the location where to save the intermediate files 

2.4. Processing Parameters tab: set the appropriate parameters to fit your 

needs of detail and hit Run (Figure II-23). 

 

Figure II-23. Example of setting the processing parameters. 

Range-Doppler Terrain correction: Radar images are acquired through the 

observation of Earth's surface from different vantage points, resulting in potential 

distortions based on the satellite's observation direction and orbit (whether 

ascending or descending). Sometimes, depending on the satellite orbit trajectory, the 

image of the area of your interest that you see in your display can appear upside-

down and/or flipped (Figure II-24).  

 

Figure II-24. Examples of image display based on the satellite's observation direction. 
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These distortions must be rectified to ensure that the obtained image accurately 

represents the actual surface. To achieve this: 

1. In the upper menu bar choose Radar > Geometric > Range-Doppler Terrain 

correction. 

2. In the pop-up window you will again see two tabs: 

2.1. I/O Parameters: as before, make sure that your last image processing 

layer and desired saving locations are specified.  

2.2. Processing Parameters: make sure to remove the check mark next to 

Mark out areas without elevation if you want to work not only with land 

area. Click Run to execute. 

After running this tool, in the Product Explorer section on the left of your screen, 

you will find a new layer, which now has your study in the correct place on the map, 

without distortions. You can look at the image by double-clicking on the data in the 

Bands subfolder (Figure II-25). 

 

Figure II-25. Image display in SNAP. 

Backscatter conversion to decibels (dB): When we talk about backscatter in 

SAR, we're referring to the strength of the radar signal that bounces back from the 

Earth's surface to the satellite. This signal can range from very weak to very strong, 

depending on the properties of the surface being observed. To make it easier to 

understand and work with, scientists convert the backscatter values to decibels (dB), 

which is a way of measuring the strength of a signal. Converting SAR backscatter to 

decibels, which employ a logarithmic scale, enhances data interpretation, 
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visualization, and analysis by compressing a wide range of values into a more 

manageable scale. To achieve this: 

I. Right-click on one of the bands of your terrain-corrected layer and select Linear 

to/from dB (Figure II-26). This will create a virtual band in your layer. 

 

Figure II-26. Pre-processing steps. 

With this step, you have finished pre-processing the SAR image and now are ready 

to use it for other applications, i.e., retrieving ship locations, identifying oil spills, 

monitoring changes in sea ice, etc. 
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III. QGIS for remote sensing data analysis and visualisation   
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A geographic information system (GIS) is a computer system for capturing, storing, 

checking, and displaying data related to positions on Earth’s surface. Although SNAP 

includes these functionalities, it lacks tools of spatial data (especially vector) 

manipulations and visualisation. Quantum GIS (QGIS) is an open-source software 

that allows spatial data collection/creation, conversion, data storage, manipulation, 

analysis, and visualisation. QGIS provides a continuously growing number of 

capabilities provided by core functions and plugins (additionally developed tools) 

therefore it is at par with proprietary softwares such as Environmental Systems 

Research Institute (ESRI) ArcGIS desktop in general-purpose GIS functionalities 

(Kumar et al., 2018). QGIS supports data in vector formats (PostGIS, Shapefiles and 

all OGR formats) and raster formats (DEM, ArcGrid, ERDAS, SDTS, GeoTIFF, etc.). 

QGIS is a preferred visualisation environment providing a modern user interface and 

map element symbology editor. The growing number of plugins is being created by 

developer communities using libraries provided or using C++ or Python. In this 

manual, we provide basic steps to import, analyse EO data in spatial and time 

context and to create a final map. For more description of QGIS tools and functions 

look for the training manual in https://www.qgis.org/en/docs/index.html.  

The QGIS desktop is available on Windows, macOS, Linux, Android and iOS, which 

can be downloaded  from https://www.qgis.org/en/site/forusers/alldownloads.html 

(Figure III-1).  

 

Figure III-1. Installing QGIS. The long-term release is suggested for a more stable run. 

After installation of QGIS, it includes other GIS software such as GRASS and SAGA; 

we open it using the QGIS Desktop. The interface of QGIS consists of several panels 

(Figure III-2): a Menu bar (with standard functions of importing, editing, saving, 

exporting, settings, plugin installing, etc.), Toolbars (as a Menu bar + additional GIS 

data editing and analysis), a Browser (for GIS data search and selection), Layers (GIS 

https://www.qgis.org/en/docs/index.html
https://www.qgis.org/en/site/forusers/alldownloads.html
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data management), a Map canvas(for visualisation of GIS layers) and a Status bar 

(for control of map display). 

 

Figure III-2. The QGIS desktop interface with imported GIS layers of SST and HELCOM sub-basins and 
further division into coastal and off-shore areas of the Baltic Sea. 

There are several plugins created for satellite data download, visualisation and 

analysis (e.g., https://www.geodose.com/2021/05/how-to-download-visualize-

sentine-qgis.html), which can be found in a Menu bar: Plugins > Manage and Install 

Plugins… In the new window (Figure III-3), select Not installed and in the search 

panel type “satellite” and plugins for satellite data will be provided, then you may 

select which one you need and install it by pressing Install Plugin… 

 

Figure III-3. The search of plugins for satellite data. 

GIS 
data 
browser

GIS 
layers 

Map 
canvas 

https://www.geodose.com/2021/05/how-to-download-visualize-sentine-qgis.html
https://www.geodose.com/2021/05/how-to-download-visualize-sentine-qgis.html
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Data import  

For the training, the sea surface temperature (SST) data (“Baltic Sea- Sea Surface 

Temperature Reprocessed”) of the Baltic Sea will be used, which  was obtained from 

the reprocessed EO products by the Copernicus Marine Service: 

https://marine.copernicus.eu/about/producers/sst-tac. The data format is the 

Network Common Data Format (NCDF); the Coordinate Reference System (CRS) is 

WGS84 projection (EPSG: 4326). For example, three data set of SST were downloaded 

from the year 2021: 15 March, 15 April and 15 May.  

For the training, additionally the vector data (polygons) containing the sub-basins 

and further division into coastal and off-shore areas of the Baltic Sea (“HELCOM 

subbasins with coastal and offshore division 2022 (level 3)”) was downloaded from 

the HELCOM GIS database:  

https://metadata.helcom.fi/geonetwork/srv/eng/catalog.search#/metadata/e5a59

af9-c244-4069-9752-be3acc5dabed. The data format is ESRI Shapefile; the CRS is 

WGS84 / Pseudo-Mercator projection (EPSG: 3857).  

The GIS data can be loaded in several ways, here it is done via Browser. In the 

Browser panel, navigate to each downloaded GIS file, and then simply drag it to the 

panel of Layer and the layer will appear in the Map canvas (Figure III-4). The base 

map was selected from a Menu bar: Web > QuickMapServices > ESRI > ESRI Gray 

(light), which was obtained from the QuickMapServices Settings under the More 

services (see more how to add a base map from the QuickMapServices plugin: 

https://docs.qgis.org/3.28/en/docs/training_manual/qgis_plugins/plugin_exampl

es.html). 

 

Figure III-4. Importing vector (shape) data. 

The window will appear for the NCDF, where select the “analysed_sst” layer and press 

Add Layers (Figure III-5).  

https://marine.copernicus.eu/about/producers/sst-tac
https://metadata.helcom.fi/geonetwork/srv/eng/catalog.search#/metadata/e5a59af9-c244-4069-9752-be3acc5dabed
https://metadata.helcom.fi/geonetwork/srv/eng/catalog.search#/metadata/e5a59af9-c244-4069-9752-be3acc5dabed
https://docs.qgis.org/3.28/en/docs/training_manual/qgis_plugins/plugin_examples.html
https://docs.qgis.org/3.28/en/docs/training_manual/qgis_plugins/plugin_examples.html
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Figure III-5. Importing raster data. 

Note, that after importing the raster layers of SST (NCDF), they did not show up over 

the imported vector layer. The question mark on the right side of the layer indicates 

that the CRS is not indicated for the raster. If GIS data is obtained from a trusted 

source, the information on CRS and other important information (date, resources, 

methods, resolution, name of creators, accuracy, etc.) should be indicated in the 

metadata or described on the website. Check the metadata of the SST raster: select 

the raster layer in the panel of Layer and press the right mouse button, then select 

Properties…  

 

Figure III-6. The imported raster layer does not appear over the Baltic Sea since there is no indicated 
CRS. 

In the new window, select Information, where you may find metadata provided for 

this layer (Figure III-7): extent, width, height, data type, etc. Under the section of 
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Band 1, you may see that the source of SST is ESA CCI and C3S L2P satellite 

product, where the units are Kelvins. Under the section of More information, you 

may find that CRS used for this raster was geographical coordinates (WGS84 

projection).  

 

Figure III-7. The properties of the raster layer. 

As we know the CRS of the rasters, it can be indicated by selecting each file and after 

pressing a mouse right button, select Layer CRS > Set Layer CRS … In the new 

window, write EPSG code of needed CRS (in this case - 4326, which is for the WGS84 

projection) and press OK (Figure III-8). Now the raster layer is over the Baltic Sea 

(Figure III-9). 
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Figure III-8. How to set the CRS (i.e., WGS84) for the layer. 

 

Figure III-9. The imported raster layer is projected and placed over the Baltic Sea. 
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When all data is imported, the first step is to unify their CRS, in this case, EPSG: 

3857 will be used according to the shape file as it was the first imported layer. The 

CRS of the Map canvas is set by the CRS of the first imported layer, although it can 

be changed by clicking with a mouse on the rightest side of the status bar (EPSG: 

3857). The transformation of CRS of raster layers can be changed by selecting each 

file and after pressing a mouse right button, select Export > Save As… In the new 

window, navigate where to save the new raster (select as GeoTIFF under the Format 

panel); rename it (e.g., “march”) under the File name panel, select relevant CRS (in 

this case, EPSG: 3857) under the panel of CRS and press OK (Figure III-10).  

 

Figure III-10. The raster layer is exported as a new layer with new CRS (EPSG: 3857). 

The new raster layer will be added to the Layer panel, while the old one can be 

removed by selecting it and pressing Remove Layer and groups (or Ctrl+D) and OK 

(Figure III-11). 
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Figure III-11. The new raster layer is added, and the old one can be removed. 

After the CRS transformation and saving of all rasters, and removing old ones, 4 

layers should be left in order to keep only necessary data for further analysis (Figure 

III-12). Otherwise, it is common to make a mistake by selecting the right layer when 

performing different GIS functions. Now the layers are ready for analysis.  

 

Figure III-12. The new saved raster layers with the same CRS (EPSG: 3857). 
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Transform raster values (cell analysis)  

Often values in cells of a raster need to be transformed in order to convert units, to 

meet the Normal distribution, etc. Current units of SST rasters are in Kelvins (Figure 

III-13), while temperature on the Celsius scale is clearer and therefore such maps are 

usually provided. The formula to convert a temperature in Kelvins (K) to Celsius (°C) 

is: Celsius (°C) = Kelvin - 273.15.  

The units of SST can be converted under a Menu bar: Raster > Raster Calculator… 

In the new window (Figure III-13), navigate where to save a new layer and name it 

(e.g., “may_C”) under the Output layer, select GeoTIFF format under the Output 

format. Double click on the raster layer (e.g., “may@1”) so it will appear in the Raster 

Calculator Expression pane, then using Operators (mathematical and logic 

functions) and numbers write the conversion formula. You can also change the 

Spatial Extent of a layer by changing the coordinates of raster corners (X and Y), 

the Resolution by changing the number of Columns and Rows and CRS. Then, press 

OK and a new map will appear in the panel of Layers. Remove all SST rasters with 

Kelvin units, leaving 3 converted layers (Figure III-14). 

 

Figure III-13. Raster Calculator to convert the SST values in Kelvins (K) to Celsius (°C). 
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Figure III-14. Converted three SST layers on the Celsius scale. To see the scale and range of other 
raster values - press with a mouse on the grey arrow (pointing towards the right direction) on the left 

side of a layer; the raster information will expand, and the grey arrow will be pointing downwards (as 
for the “march_C” raster). 

Spatial statistics 

Working with GIS data often requires a summary of data over some spatial units, e. 

g. average of SST in the coastal and offshore areas. SST values can be extracted by 

polygons of HELCOM subbasins, wherein the SST statistics can be calculated. The 

polygons can be selected directly on the Map canvas using the feature selection 

button  or feature selection from the attribute table (auxiliary data about spatial 

features such as names, date, area, etc.)  on the Toolbar.  

For the training, select the open sea area of the Eastern Gotland Basin using the first 

selection tool and the second tool can be used to select the coastal waters of 

Lithuania since it is a relatively narrow and small area. The first selection tool allows 

you to select features (in this case - polygons) by a mouse click (Select Feature(s)), 

by drawing a polygon (Select Features by Polygon or Freehand) or radius (Select 

Features by Radius). A certain polygon (e. g. the Eastern Gotland Basin) can be 

located on the Map canvas by adding names of the open sea features stored in the 

attribute table: select the vector layer of the HELCOM subbasins and press a mouse 

right button and select Properties… In the new window (Figure III-15), select Labels 

and in the upper panel with “No Labels” change to the “Single Labels” and select 

“open_sea” under Value, then press OK. The names of open subbasins will appear 

on the Map canvas (Figure III-16). Now you can select the Eastern Gotland Basin 

using the first option: click by mouse on this polygon, where the selected area will 

be indicated by yellow colour.  
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Figure III-15. Add labels of open sea features from the attribute table. 

 

Figure III-16. Labels of open sea features from the vector layer of the HELCOM subbasins and the 
selected Eastern Gotland Basin (indicated by yellow colour).  

The second feature selection option allows select features in several ways: by value, 

expression, all and invert selection. You may choose the selection by value and the 

new window will appear (Figure III-17). Under the country panel, type “Lithuania” 
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and on the right side select Equal to (=), choose Add to Current Selection under 

the Select Features drop bar since you have already selected one polygon (the 

Eastern Gotland Basin). Then close the window and you can see on the Map canvas 

both areas of interest (open sea of the Eastern Gotland Basin and the coastal waters 

of Lithuania) are indicated in yellow (Figure III-18). 

Figure III-17. Select features by value from the vector layer of the HELCOM subbasins.  

 

Figure III-18. Selected (indicated by yellow colour) areas of interest: the open sea of the Eastern 
Gotland Basin and the coastal waters of Lithuania.  
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Zonal statistics tool can be used to extract the SST values over selected polygons of 

HELCOM subbasins and to calculate the SST statistics (e.g., mean). Under the search 

panel of the Processing Toolbox, type the “zonal” and it should narrow down the 

GIS tools, where you may find the Zonal statistics tool (Figure III-19). In the new 

window, select vector layer of HELCOM subbasins under the Input layer, click on 

Selected features only (otherwise analysis will be performed for all polygons of the 

vector layer), select one of SST raster (e.g., “may_C”), select Mean (or other statistics) 

under Statistics to calculate and press OK, and choose how you want to save a 

new vector layer under the Zonal Statistics panel (in this case Create Temporary 

Layer will be used). Then press Run and Close. 

 

Figure III-19. The Zonal statistics tool in the Processing Toolbox. 

A new temporary vector layer “Zonal Statistics” will appear in the panel of Layers 

(Figure III-20). The results of statistical analysis (i.e., means) can be found in the 

attribute table, after the selection of this layer and press of a mouse right button and 

selection of the Open Attribute Table. Under the column “_mean”, you can see that 

mean SST is higher in the coastal waters (9.8 °C) than in the open sea (7.4 °C) on 15 

May 2021. 



54 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

54 

 

 

Figure III-20. The results (under the column “_mean”) of the zonal statistics tool in the attribute table of 
the new vector layer. 

If you do not want to lose data by averaging, the actual SST values can be extracted 

by points from the raster cells. This can be done by a layer of points imported by you 

(i.e., x and y coordinates of interest sites) or created using the vector tools (under a 

Menu bar: Vector > Research Tools) such as Regular points…, Random Points in 

Lines…, Random Points in Polygons… (https://freegistutorial.com/how-to-create-

random-points-inside-polygon-on-qgis/). For the training, the first approach will be 

used in order to get the same SST values. Copy provided coordinates (Table III-1) to 

any text format file such as a Comma Separated Values (.csv) or standard Text 

document (.txt). The later format was selected to save it in the notepad (Figure III-21).  

Table III-1. The coordinates (with CRS of EPSG: 3857) of sites in the Eastern Gotland Basin. 

Site nr. x y 

1 2258546.421 8009988.772 

2 2240903.966 7866063.481 

3 2218618.760 7726780.942 

4 2195405.003 7576355.799 

5 2175905.448 7430573.407 

 

https://freegistutorial.com/how-to-create-random-points-inside-polygon-on-qgis/
https://freegistutorial.com/how-to-create-random-points-inside-polygon-on-qgis/
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Figure III-21. The notepad (i.e., sites.txt) with copied coordinates of sites. 

The text file with the coordinates (.txt or .csv) can be opened in QGIS from a Menu 

bar  (or Ctrl+shift+t). In the new window (Figure III-22), navigate to the text file 

under the File name, indicate file type and column delimiters (in this case - Tab) 

under the File Format, change the CRS to EPSG: 3857 and inspect the data 

structure under the Sample Data. If you can recognize the columns and values, 

press Add and Close.  

 

Figure III-22. Import of sites.txt (points of sites of interest). 

The imported sites will appear in the Map display, where the mean SST raster was 

removed in order to keep only necessary layers (Figure III-23).  
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Figure III-23. The imported sites of interest. 

For the extraction of SST values from the rasters to the imported points, you will 

need an additional tool which can be added from a Menu bar: Plugins > Manage and 

Install Plugins… In the new window (Figure III-24), select Not installed and in the 

search panel type “point sampling” and the Point sampling tool will be provided, then 

press Install Plugin. The icon of this plugin will appear on the toolbar. 

 

Figure III-24. The Point sampling tool added from the plugins. 
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Press the icon  of installed plugin (Point sampling tool) and in the new window 

(Figure III-25) select General, where select point layer (“sites”) under the Layer 

containing sampling points:, then select attributes to include in the new vector 

layer (points) such as the site number, the values of SST from three rasters under 

the Layers with fields/bands to get values from:, and navigate where to save the 

new vector (e.g., “site_extr”) and in which format (in this case shape file - .shp) under 

the Output point vector layer. Then press OK. 

Figure III-25. Selection of raster layers to extract to the point vector using the Point sampling tool. 

The extracted raster values from 3 layers (March-May 2021) to the 5 sites of point 

vector (“site_extr”) can be found in the attribute table (Figure III-26). The table can 

be selected and copied to other documents using the icon on the attribute table  

(or Ctrl+C). 



58 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

58 

 

 

Figure III-26. Extracted raster values from 3 layers (March-May 2021) to the point vector (“site_extr”) 
and its attribute table with extracted SST values for 5 sites. 

Time statistics.  

The satellite products can provide a long time series of data; therefore, it can be 

necessary to summarise data not only spatially but also temporarily. For the training, 

you may assess the mean SST during March-May 2021 in the open sea of the Eastern 

Gotland Basin and the coastal waters of Lithuania. The raster layer of SST covers 

the North Sea and Atlantic Ocean, which is outside of our interest, therefore it is 

recommended to clip rasters before analysis, which will reduce processing time, 

especially having high resolution data and long-time series.  

The raster clipping can be performed in a Menu bar (Figure III-27):  Raster > 

Extraction > Clip Raster byMask Layer… In the new window, select the raster of 

SST (e.g., “march_C”) under the Input layer and clipping polygon under the Mask 

layer (i.e., “Zonal Statistics”). You may indicate Source and Target CRS if needed 

and other options (in this case we use the default). The name of the new raster can 

be provided (“march”) under Clipped (mask) and then press Run. Repeat the same 

for all rasters and then remove the unclipped rasters from a panel of Layers to keep 

the Map canvas clean (Figure III-27).  



59 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

59 

 

 

Figure III-27. The clipping of SST raster by mask (polygon of the open sea of the Eastern Gotland Basin 
and the coastal waters of Lithuania). 

 

Figure III-28. The clipped rasters of SST by mask. 

Now, the mean SST for the time series can be calculated by the Raster calculator 

(Under a Menu bar: Raster > Raster Calculator…) as it was used for the 

transformation of raster cell values (Figure III-13). In the new window (Figure III-29), 
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navigate where to save a new layer and name it (e.g., “mean”) under the Output 

layer, select GeoTIFF format under the Output format. In the Raster Calculator 

Expression pane, type the formula to calculate mean SST using the raster layers 

from the Raster Bands pane, and mathematical functions using the Operators and 

numbers. You can also change the Spatial Extent of a layer by changing the 

coordinates of raster corners (X and Y), the Resolution by changing the number of 

Columns and Rows and CRS. Then, press OK and a new clipped raster will appear 

in the panel of Layers (Figure III-30). 

 

Figure III-29. Raster Calculator to calculate the mean SST values for each cell from March-May 2021. 

 

Figure III-30. The mean SST values for each cell from March-May 2021 in the Eastern Gotland Basin 

and the coastal waters of Lithuania. 
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Reclassify raster 

Often raster values are summarized by classifying them to certain groups in order to 

show spatial patterns: temperature anomalies, upwelling events, etc. You can 

classify the mean SST raster to several groups. The number of groups can be decided 

after inspecting the histogram of SST (Figure III-31), which can be obtained by 

selecting the layer and after pressing a right mouse button, selecting Properties... 

and Histogram.   

 

Figure III-31. The histogram of mean SST raster. 

From the histogram of SST (Figure III-31), we decided to classify raster values into 3 

groups: < 4 °C, 4-5 °C and > 5 °C. This can be done using the Raster Calculator tool, 

which was introduced in the chapter of cell analysis. After selection of Raster > 

Raster Calculator… under a Menu bar, in the new window (Figure III-13), navigate 

where to save a new layer and name it (e.g., “mean_class”) under the Output layer, 

select GeoTIFF format under the Output format. In the Raster Calculator 

Expression pane, by double clicking on the raster layer (“mean@1”) and using 

Operators (mathematical and logic functions) and numbers write the conversion 

formula. You can also change the Spatial Extent of a layer by changing the 

coordinates of raster corners (X and Y), the Resolution by changing the number of 

Columns and Rows and CRS. Then, press OK and a new map will appear in the 

panel of Layers.  
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Figure III-32. Raster Calculator tool to classify SST values into 3 groups: 1 (< 4 °C), 2 (4-5 °C) and 3 (> 
5 °C). 

The grey scale of classified raster is not very useful for inspecting spatial patterns of 

SST, therefore, you may change the colour of scale. Select the layer and after pressing 

a right mouse button, select Properties... and Symbology (Figure III-33). Then, 

select Singleband pseudocolor under the Render type pane, Discrete under the 

Interpolation pane, Reds colour scale the Color ramp pane, Equal interval under 

the Mode pane, 3 groups under the Classes pane, you may change value precision 

under the Label precision pane or their labels under Label pane, and press OK. 
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Figure III-33. Change of classified SST grey scale into 3 colours. 

From the classified SST raster several SST patterns can be found. The warmest area 

was in the southern part of the Baltic Sea and in the coastal sections of Klaipeda-

Sventoji and Liepoja, where the riverine waters enter the coastal waters (Figure 

III-34). The lowest SST was located in the northern part and near the Gulf of Riga. 
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Figure III-34. The classified the mean SST raster from March-May 2021 in the Eastern Gotland Basin 
and the coastal waters of Lithuania. 

Creating a map 

Creating maps is usually the final step of EO data analysis. In QGIS, maps can be 

2D, 3D type or plotted along a profile line 

(https://docs.qgis.org/3.28/en/docs/user_manual/map_views/index.html).  

The 2D maps can be created mainly by two approaches: decorating a Map canvas or 

using a Print layout 

(https://docs.qgis.org/3.28/en/docs/user_manual/print_composer/overview_com

poser.html#sample-session-for-beginners). The second approach has more tools and 

functions for map making, where you can size, group, align, position, and rotate each 

element and adjust their properties to create your layout. The layout can be printed 

or exported to image formats, PostScript, PDF or to SVG. You can save a layout as a 

template and load it again in another session. Finally, generating several maps based 

on a template can be done through the atlas generator 

(https://docs.qgis.org/3.28/en/docs/training_manual/forestry/forest_maps.html).  

Thus, the Print layout approach was selected for the training, to create a map with 

the mean SST (March-May 2021) with overlaid 5 sampling sites in the Eastern 

Gotland Basin and the coastal waters of Lithuania. Before creating the map, the 

layers should be understandable on a Map canvas. Firstly, you may want to add 

labels of the site numbers (this information is stored in the attribute table). You can 

do this by selecting this layer and pressing a right mouse button and selecting 

Properties…, select Single Labels under the Labels pane and the “site nr.” under 

the Value panel (Figure III-35). You may also change font, style, size, colour and 

opacity and press OK.  

https://docs.qgis.org/3.28/en/docs/user_manual/map_views/index.html
https://docs.qgis.org/3.28/en/docs/user_manual/print_composer/overview_composer.html#sample-session-for-beginners
https://docs.qgis.org/3.28/en/docs/user_manual/print_composer/overview_composer.html#sample-session-for-beginners
https://docs.qgis.org/3.28/en/docs/training_manual/forestry/forest_maps.html
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Figure III-35. Adding the labels of study site numbers to a map canvas. 

Although you may use the classified mean SST layer, for the final map actual mean 

SST values could be used in order to make it more realistic. The actual mean SST 

map has a grey scale; therefore, it is recommended to change it into colourful ramp. 

For this, elect the layer and after pressing a right mouse button, select Properties... 

and Symbology (Figure III-36). Then, select Singleband pseudocolor under the 

Render type pane, 3.4 and 5.8 respectively under Min and Max, Linear under the 

Interpolation pane, Reds colour scale the Color ramp pane, Continuous under the 

Mode pane, you may change value precision under the Label precision pane or their 

labels under Label pane, and press OK. 
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Figure III-36. The change of the mean SST grey scale into colour ramp. 

The layer of the sampling points and the mean SST with changed colour ramp (Figure 

III-37) are ready to be included in the final map.  

Figure III-37. Ready layers of the sampling sites and the mean SST with the changed colour ramp. 
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In a Toolbar, select New Print Layout  (Ctrl+p), which allows to create maps, 

atlases, and print them or save them as image, PDF or SVG files. In the new window, 

you will be prompted to choose a title for the new layout (Figure III-38). 

 

Figure III-38. Create a new Print Layout. 

The print layout provides a blank canvas that represents the paper surface when 

using the print option in a new window (Figure III-39). On the left side of a canvas, 

there are tools to add print layout items: the current QGIS map canvas, text labels, 

images, legends, scale bars, basic shapes, arrows, attribute tables and HTML frames. 

In this toolbar you also find buttons to navigate, zoom in on an area and pan the 

view on the layout a well as buttons to select any layout item and to move the 

contents of the map item. 

For the training, you may add the layers from the Map canvas using Add Map tool 

(Figure III-39). After selecting this tool drag a mouse to on the blank canvas to mark 

an area where the map should be displayed (in this case – over the whole canvas).   

 

Figure III-39. Initial view of the print layout (left) and adding the layers from the Map canvas using Add 
Map tool (right). 

The next important feature of a map is a legend that explains the meanings of the 

symbols used. A legend item can be added selecting the Add Legend tool   (Figure 

III-40) and manipulate it the same way as Add Map tool. The layer symbols from the 

Map canvas will appear in the selected area.  

https://docs.qgis.org/3.28/en/_images/mActionAddLegend.png
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Figure III-40. Selection of area where a legend will be displayed (upper) and inserted legend with the 
layer symbols from the Map canvas (below). 

All layer names and symbols displayed on the Map canvas will be provided on the 

legend area, therefore to remove unnecessary layers (e.g., a base map) you can select 

them (after selecting the legend plot) using Ctrl in the Item Properties under the 

Legend Items panel (also unselect Auto update) and remove them by pressing  

Remove selected item(s) from legend (Figure III-41). 

 

Figure III-41. Removing of unnecessary layer from the legend (above) and the view after the remove 
(below). 
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Then you have a final set of layers, you may want to change their names in a legend 

plot, as usually they are not clear or miss some information. For instance, the 

imported layer name of study sites you may want to change it to “study site” (Figure 

III-42). This can be done by selecting the layer name under the Legend Items panel 

in the Item Properties and press  Edit selected item properties and you may 

change it under the new pane of Label. 

 

Figure III-42. Changing then names of layers in the legend plot (above) and the view after the change 
(below). 

Using the same approach, the name of the mean SST layer can also be changed as 

in the Figure III-43. 
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Figure III-43. Changing then names of the mean SST layer in the legend plot (above) and the view after 
the change (below). 

Another attribute of a map is a scale bar, which can be added using the  Add 

scalebar button from the left side toolbar (Figure III-44). A scale bar can be moved 

(e.g., bottom left side), its style and size can be also changed according to needs. In 

this case, the Line Ticks Up style was selected under the Style pane in the Main 

Properties panel, and 1 mm height was set under the Height and Subdivisions 

height panes in the Segments panel.  
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Figure III-44. Selecting a scale bar (above), adding it to a map (middle) and changing its appearance 
(below). 

The North arrow is often used attribute of a map, which can be added using the  

Add North Arrow button from the left side toolbar (Figure III-45). The North arrow 

can be moved, its style and size can be also changed according to needs. In this case, 

the arrow with “N” symbol was selected from SVG Images pane after selecting the 

folder of arrows under the SVG groups pane in the SVG browser panel and placed 

on the top right side of the map. 
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Figure III-45. Selecting a North arrow (above), adding it and changing its size and style (middle), and a 
final view after adjustments (below). 

You are almost done with a map. It is recommended to also add a grid of coordinates 

in order someone could georeference a map or its objects if only image is provided 

(e.g., in a report or article). You may add a grid of coordinates after selecting the 
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Select/Move item button from the left side toolbar (Figure III-46) and add a grid by 

clicking the Add a new grid button under the Grids pane in the Item Properties 

panel. An appearance of a grid of coordinates can be modified after pressing the 

Modify Grid… button. Under the Appearance panel, mark the Enable grid pane, 

which will allow you to select Cross under the Grid type pane and type 100000 for 

X and Y coordinate intervals under the Interval panes, and also change colour of a 

grid (e.g., white) under the Line style pane. 

 

 

 

Figure III-46. Selecting a map canvas in the print layout (upper) and adding a grid of coordinates 

(middle), and changing its properties (below). 
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The added grid is without coordinates, which can be labelled by adding a frame of 

ticks for coordinates under the Frame panel in the Appearance panel. Select 

Interior Ticks under the Frame style pane and change colour (e.g., white), select 

Latitude/Y Only under the Left divisions panes and Right divisions panes, and 

Longitude/X Only under the Top divisions panes and Bottom divisions panes 

(Figure III-47). The labels of coordinates can be added by selecting the Draw 

Coordinates under the Appearance panel, where you may modify appearance and 

position of labels.  

 

 

Figure III-47. Adding a frame of ticks for coordinates (upper) and labels of coordinates (bellow). 
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For the final makeup of a map, you may add title or other labels of objects on a map 

(e.g., “Baltic Sea”). This can be done by selecting the  Add Label button from the 

left side toolbar (Figure III-48). You may also modify font, size, colour and alignment 

of a label under the Appearance panel. 

 

 

Figure III-48. Adding the label “BALTIC SEA” on the map. 

Finally, the print layout project can be saved using Ctrl+s and the map can be 

exported as image under the Menu bar: Layout > Export as Image... (Figure III-49). 

If a warning window with the note of “Some WMS servers (e.g., UMN map server) have 

a limit for the WIDTH and HEIGHT parameter. Printing layers from such servers may 

exceed this limit. If this is the case, the WMS layer will not be printed” will pop up - 

press Close. Then, navigate where to save the map and press Save. A new window 

with properties of image will appear, where you may modify resolution and size of 

page, and press Save. 



76 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

76 

 

 

Figure III-49. Saving a map as image (.jpg).  

The image of final map can be viewed in the Figure III-50. 

 

Figure III-50. A final saved map as image. 
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IV. Sea Surface Temperature retrievals from remote sensing (Toma) 
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Sea Surface Temperature (SST) is one of the key physical properties of the ocean, a 

knowledge of which is essential for understanding the rate of the ongoing climate 

change, as the variability of SST has a significant local and remote influence on the 

global climate changes through the distribution and transport of heat and moisture 

(Ruela et al., 2020). SST is also fundamental for understanding, quantifying, and 

predicting complex interactions between the ocean and the atmosphere, e.g., for 

understanding how the heat from the sun is redistributed across the global oceans 

and how it directly impacts large- and small-scale weather and climate patterns 

(O’Carroll et al., 2019). SST variations influence ocean circulation and primary 

production and can impact species abundance, distribution, and behaviour (Biguino 

et al., 2023). It is also an important indicator of productivity, thermal pollution, 

upwelling areas and might be used as an indicator of stress to ocean ecosystems 

(Fingas, 2019). Local variations of SST are important for regional climate and, 

through the influence on meteorological conditions, SST might have various impacts 

on socio-economic activities in the coastal regions, affecting maritime safety, military 

operations, ecosystem assessment, fisheries and tourism, transport and energy, 

human health, food security and environmental policy (O’Carroll et al., 2019). In 

turn, all of this makes monitoring changes in SST an important aspect for 

understanding and mitigating the impacts of climate change, in weather predictions 

and various model simulations.   

SST, in general, is a difficult parameter to define precisely, as the upper ocean (~10 

m) has a complex and variable vertical temperature structure related to the turbulent 

regime and air-sea fluxes of heat, moisture and momentum in this layer (Garcon et 

al., 2014). So, in order to understand how satellites are measuring sea surface 

temperature, one needs to understand, what the sea surface temperature is, as it 

depends on how and where is measured (Figure IV-1; Table IV-1). 

 

Figure IV-1. The schematic diagram summarizing the definition of SST in the upper 10 m of the ocean in 
strong wind conditions / night time (red) and low wind speeds during the day (black) proposed by 

GHRSST. © GHRSST – The Group of High Resolution Sea Surface Temperature. 
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Table IV-1. More detailed explanation of vertical structure of SST (according to Donlon et al., 2012). 

 

SST Data Acquisition: Satellite SST data can be retrieved from infrared sensors 

like Sentinel-3 SLSTR of ESA, MODIS of NASA and AVHRR of NOAA and others. In 

this manual, applications of SST from Sentinel-3 SLSTR and MODIS Aqua/Terra will 

be mainly presented as due to their spatial and temporal resolution and relatively 

long data record they are widely used in different studies and, therefore, are a 

valuable source for the analysis of SST changes in the Baltic Sea and its coastal 

lagoons. 

SLSTR: Sea surface temperature from Sentinel-3.  

ESA’s SLSTR (the Sea and Land Surface Temperature Radiometer) is a multi-channel 

imaging radiometer responsible for taking sea (and land) surface temperature 

measurements on Sentinel-3A and B. The instrument provides global sea surface 

temperature measurements with zero bias and uncertainties of ± 0.3 K. SLSTR has 

a spatial resolution of 1 km, with less than half a day revisit time (with Sentinel-3 A 

and B) and a swath of 1400 km. Data is available since May 2016. 

More information:  

• https://sentinel.esa.int/web/sentinel/missions/sentinel-3 

• https://docs.sentinel-hub.com/api/latest/data/sentinel-3-slstr-l1b/ 

Sentinel-3 SLSTR Level-2 water surface temperature (WST) data acquisition:  

▪ Level-2 WST data products are freely available to the public. 

▪ Data is available to registered users.  

▪ Registered users can obtain Sentinel-3 SLSTR Level-2 WST data by searching: 

EUMETSAT Data Store. 

https://docs.sentinel-hub.com/api/latest/data/sentinel-3-slstr-l1b/
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▪ Data Store can be accessed through the Earth Observation Portal (Figure 

IV-2 a) or directly via https://data.eumetsat.int (Figure IV-2 b). To get the 

most out of the service, new users will require a user registration, and the 

EUMETSAT data policy applies. More information: 

https://www.eumetsat.int/eumetsat-data-store 

▪ When entering the browser, define Time range, additional Filters, select Area 

of Interest (AOI) via entering the coordinates or by drawing polygon on the 

map by using toolbars at the righthand side of the map. Data can be 

downloaded directly from the browser by selecting the file to download or, if 

more data are needed, the results can be added to the cart and an order can 

be placed. A notification email will be sent with a link for downloading the 

data.

 

Figure IV-2. Data Store access through the (a) Earth Observation Portal and (b) direct access from 
EUMETSAT. 

NOTE: Sentinel-3 satellite images downloaded from the archive are 

zipped and should be unzipped prior to use. Some images might also 

be relatively big in size (e.g., the noncompressed size is 2.2GB for 

the marine Level-2 stripe, more information at sentinel.esa.int). 

https://eoportal.eumetsat.int/userMgmt/login.faces
https://data.eumetsat.int/
https://www.eumetsat.int/data-registration
https://www.eumetsat.int/data-registration
https://www.eumetsat.int/eumetsat-data-store
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NASA MODIS (or Moderate Resolution Imaging Spectroradiometer) is a key 

instrument aboard the Terra and Aqua satellites. The first MODIS instrument was 

launched aboard Terra in 1999; the second MODIS instrument was launched aboard 

the Aqua platform in 2002, therefore, it has a long data record of the SST spanning 

from year 2000 to this day. MODIS SST data products have a spatial resolution of 1 

km.  

More information: 

https://modis.gsfc.nasa.gov/about/ 

https://ladsweb.modaps.eosdis.nasa.gov/missions-and-measurements/modis/ 

MODIS Terra/Aqua Sea surface temperature (SST) data acquisition:  

▪ SST data products are freely available to the public. 

▪ Registered users can obtain MODIS SST data by searching MODIS SST data 

product catalogue and submitting an order for selected archived products at 

oceancolor.gsfc.nasa.gov (Figure IV-3). 

▪ After entering the Level 1 & 2 Browser, (1) define the Data you want to 

download; (2) define selection criteria; (3) view results (click on Find swaths) 

& (4) select data to order / download, as demonstrated in Figure IV-3. 

 

Figure IV-3. MODIS Terra/Aqua data acquisition. 

Case study: SST analysis: Sentinel-3 and MODIS observations of sea (water) 

surface temperature are widely used for the coastal upwelling1 analysis. Because of 

its frequent nature and spatial extent, coastal upwelling may be considered as one 

of the main factors, affecting the circulation of the Baltic Sea, and thus, its ecosystem 

 

1 The term “Coastal upwelling” describes the vertical flux of water moving upwards at the coast, which, 

in the case of a thermally stratified water column, brings cooler, nutrient-rich subsurface waters to the 

surface (Leppäranta and Myrberg, 2009).   

 

https://modis.gsfc.nasa.gov/about/


82 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

82 

 

functioning. Comprehensive upwelling studies are important assessing regional 

variability of water and energy exchange, salinity dynamics and response of marine 

ecosystems to extreme events. In this exercise an example of upwelling event that 

took place on 10th of June 2023, at the SE coast of the Baltic Sea, will be 

demonstrated. 

Data used:  

Sentinel-3B Level 2 SST image acquired on 10 June 2023, 19:12 UTC 

(S3B_SL_2_WST____20230610T191225_20230610T205325_20230612T051645_6059_080_

241______MAR_O_NT_003.SEN3)  

and 

MODIS Aqua Level 2 SST image acquired on 10 June 2023, 02:00 UTC 

(AQUA_MODIS.20230610T020001.L2.SST4.NRT.nc) 

For the characterization of upwelling parameters ESA SNAP software will be used. 

First, load the satellite data into SNAP. Note, that the NTC product contains data of 

the full orbital track, and it will be displayed as a long stripe covering a full orbit 

(Figure IV-4 a) or you might select an individual tile (NRT product) (Figure IV-4 b) to 

download. 

 

Figure IV-4. An example of (a) full orbital track from NTC product and (b) a single tile from NRT product. 

In this excercise, an example of full orbital track is presented (Figure IV-4 a). After 

loading Sentinel-3 SLSTR data product into SNAP, select Bands > Sea Surface 

Temperature. After identifying the location of your area of interest (AOI) (b) zoom the 

image until it meets your AOI requirements (Figure IV-5 c-d) and then create a 

Spatial Subset from View. In this exercise for both, Sentinel-3 and MODIS SST data 

products the Spatial subset was created using Geo Coordinates (North latitude 

bound 56.18, West latitude bound 19.09, South latitude bound 54.87 and East 

latitude bound 22.97) and Band subset (sea_surface_temperature, lat, lon bands 

were selected). 

As one may notice, the image still need reprojection (Figure IV-5) so it would be 

properly oriented. In this excercise, UTM zone N34 was used and the resolution (Pixel 

sizeX and PixelsizeY) was 1000×1000 m for both satellite images. 
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Figure IV-5. Example of selecting area of interest before reprojection. 

Now, let‘s analyse SST patterns in horizontal transect during coastal upwelling using 

Profile Plot tools. To compare the SST changes in two satellite SST images (one taken 

at night, one in the evening), one may draw a transect on the map and then Export 

transect as Shape file (Figure IV-6 a), so it could be imported (Figure IV-6 b) and used 

at the same location for the analysis of the second satellite image.  

 

Figure IV-6. (a) exporting/(b) importing a Shape file. 

Then, using Analysis > Profile Plots tool one can analyse SST data at both profiles 

and asses e.g., the width of coastal upwelling, compare SST in the upwelling zone 

and in the ambient waters and other. The Chart can be saved as Image (Figure IV-7 

NOTE: Sea surface temperature in SLSTR product is in degrees 

Kelvin, therefore using Band Maths, recalculate it to degrees Celsius 

(read chapter II (SNAP) for more details on Band Maths). 
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a) or Export Mask Pixels of both transects option is available, enabling to 

compare/analyse them, e.g., in Excel (Figure IV-7 b) or other software. 

 

 

Figure IV-7. Examples of exporting data. 

Using Pin placing tool in S-3 SLTSR satellite image and then transferring pins to 

MODIS SST map, we will compare SST at the same locations in both satellite images 

(Figure IV-8). 

 

Figure IV-8. Example of analysis using Pin placing tool data extraction option. 

One can see that the more developed coastal upwelling in the SE Baltic Sea coast is, 

the lower are the SST values, i.e., lower SSTs are recorded in the S3 SLSTR satellite 

SST image. 

Create an SST map using SNAP: Adding map elements to the map is possible 

via Layer > Layer manager. After opening Layer manager click on the + icon  and 

select Mapping Tools > Next where you can add North arrow, scale, or logo. Selecting 

ESRI Shapefile enables one to add shapefiles, e.g., to demonstrate, where the 

analysed transect was located, as was in demonstrated case. The legend can be 

added manually after Exporting View as Image and Exporting Colour Legend as 

Image. In Figure IV-9 a map created using SNAP tools is presented.  
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Figure IV-9. Example of a map created via SNAP. 

 

  

NOTE: GIS functionalities are not well elaborated in SNAP as 

it is not a GIS software, therefore, it is recommended to use 

other software, such as QGIS for creation of more professional 

maps. More information can be found in Chapter III.  
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V. Ice cover detection from satellite images 
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In recent years, the monitoring and analysis of ice cover in lagoons and lakes have 

become increasingly important due to the significant influence of ice dynamics on 

the environment and human activities. Satellite remote sensing offers a powerful tool 

for detecting and studying ice cover on a large scale, providing valuable insights into 

the spatial and temporal variations of ice formation, growth, and melt (Figure V-1). 

This section explores the application of satellite imagery in detecting and analysing 

ice cover in lagoons and lakes. It delves into the techniques, methodologies, and 

challenges involved in utilising satellite data to monitor ice extent, thickness, and 

phenology. By leveraging satellite observations, researchers and stakeholders can 

enhance their understanding of ice cover dynamics, contribute to climate studies, 

and support decision-making processes related to winter resource management, 

navigation safety, and ecological conservation. 

Ice cover observations: Ice cover in aquatic environments is a dynamic and 

critical component of Earth's climate system, influencing ecological processes, 

hydrology, and human activities. 

Observing ice cover using traditional methods poses challenges due to 

inaccessibility, limited spatial coverage, and time-consuming fieldwork. Additionally, 

the rapid seasonal variability of ice conditions further complicates accurate 

observations. 

Remote sensing plays a crucial role in overcoming these challenges. With its ability 

to provide large-scale coverage, timely and repeated observations, and enhanced 

safety for researchers, remote sensing offers a comprehensive view of ice cover 

dynamics. 

Integrating data from various sensors and sources enables assessing environmental 

changes, understanding ecosystem responses, and making informed decisions for 

sustainable management of aquatic resources. 

 

Figure V-1. Advantages of Remote Sensing.  
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Remote sensing's cost-effectiveness, rapid response capability, and integration with 

other environmental data make it a valuable tool for monitoring ice cover in aquatic 

environments. By leveraging remote sensing capabilities, researchers and decision-

makers can efficiently monitor ice cover, study its variations, and gain valuable 

insights into the impacts of climate change and other environmental factors on ice-

covered regions. 

Additionally, remote sensing data can support the development of ice prediction 

models, assist in navigation planning, and aid in mitigating potential hazards 

associated with changing ice conditions. 

Ice types: Satellite observations play a crucial role in studying the dynamics, 

extent, and variations of different types of sea ice, providing valuable data for climate 

research, navigation, and environmental monitoring. 

Different ice types (Figure V-2) may not always be easily detectable or distinguishable 

in satellite imagery. This is particularly true for the initial ice forms (i.e., frazil, grease 

ice, etc.), which may be too small to be detected from space. 

 

 

However, when these initial ice 

forms consolidate, cover a large 

area of the water body, and 

change its surface patterns, then 

it can be detected in the satellite 

images. 

In situ measurements, field 

campaigns, and numerical 

modelling efforts are often 

employed to complement and 

validate satellite observations, 

particularly for studying these 

early stages of ice formation and 

the dynamics of smaller ice types. 

Figure V-2. Example of different ice types. 

 

Ice types determined by satellite: Satellite sensors generally have a limited 

spatial resolution because they are designed to cover larger-scale areas. As 

mentioned before, this means that they may not be able to capture fine-scale details 

of small ice features. Instead, their primary focus is on capturing larger-scale ice 

formations and patterns. Some of the types of ice features that satellite sensors are 

particularly well-suited to capture (Figure V-3) include: 

Frazil ice - small, needle-like ice 
crystals that form in turbulent or 
supercooled water. It often appears 
as a slushy mixture of floating ice 
particles.

Grease ice - a thin, soupy layer of 
floating ice that forms on the water
surface when frazil ice crystals 
accumulate and freeze together. It 
often appears as a greasy or slushy 
layer.

Pancake ice - circular or rounded 
pieces of ice, having raised edges 
and a depressed center. It forms 
when the frazil ice or grease ice 
crystals collide, freeze together, and 
accumulate into circular discs.

wordpress.com 

noaa.gov 

livescience.com 

https://summitvoice.wordpress.com/2010/05/10/the-daily-photo-frazil-ice-on-dillon-reservoir/
https://www.pmel.noaa.gov/foci/ice07/images_selectHyrenbach/pages/GreaseIce%20by%20Kathy%20Kuletz.html
https://www.livescience.com/ice-pancakes-scotland
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Figure V-3. Types of ice features. 

Ice thickness: In the decade when radar altimeters were introduced, they became 

useful devices for measuring the height of the ice above the water. It sends pulses 

toward the ice surface, and the time taken for the signal to return provides the height 

of the ice above the water level. 

By subtracting this ice cover height from the measured water surface level, one can 

estimate the thickness of the ice above the water level. However, this calculated 

thickness only reflects the part of the ice above the water - the part of the ice 

submerged under the water is not estimated. Estimating the thickness of the 

submerged ice is challenging (Figure V-4). 

 

Figure V-4. An example of the submerged ice detection challenges. 

Ice ridges - elevated
formations that occur
when sea ice is
compressed and pushed
together.

Fast ice - anchored to 
the coastline or other 
fixed structures and 
remains stationary, 
does not drift with 
currents.

Ice floes - individual 
pieces or chunks of ice 
floating on the surface 
of the water.

noaa.gov 

nasa.gov 

Polynyas- areas of 
open water 
surrounded by sea ice. 
They tend to be larger 
scale and more stable.

Leads - linear 
opennings or channels 
in the ice cover. They 
tend to be narrower 
and more transient 
than polynyas.

Pack ice - a collection 
of loosely packed ice 
floes and various ice 
formations.

mdpi.com 

nasa.gov 

globalcryospherewatch.org 

nasa.gov 

https://www.pmel.noaa.gov/arctic-zone/ice-rubble-pressure.html
https://eoimages.gsfc.nasa.gov/images/imagerecords/151000/151418/amundsengulf_amo_2023142_lrg.jpg
https://www.mdpi.com/2072-4292/11/17/2059
https://earthobservatory.nasa.gov/images/76474/polynya-off-the-antarctic-coast
https://globalcryospherewatch.org/about/about_seaice.html
https://earthobservatory.nasa.gov/images/76474/polynya-off-the-antarctic-coast
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The submerged part is typically not measured directly by satellite sensors or 

altimeters. Instead, it is often inferred or modelled using ice thermodynamic models 

that consider factors like ice density, temperature, and buoyancy. However, this 

introduces some uncertainties in the final estimation. 

Snow cover on the ice surface can also introduce errors in ice thickness estimation. 

More snow weight means more ice will be submerged. These errors are significant 

because only a portion of the ice is assumed to have emerged above the water. 

Ice thickness estimation is more complex and often requires additional data beyond 

satellite imagery. For example, by combining data from satellite measurements with 

thermodynamic models and additional field measurements of the ice cover, it is 

possible to calculate the growth of ice thickness quite efficiently. 

Understanding ice through a variety of sensors: Ice cover monitoring from 

space relies on various sensors operating in different parts of the electromagnetic 

spectrum (Figure V-5). These sensors include those operating in the visible part of 

the spectrum, passive microwave sensors, and radars. Each sensor type has distinct 

specifications and characteristics influencing its suitability for ice monitoring. 

High resolution is crucial to assess the monitored surface and accurately analyse 

small areas. Sensors with higher spatial resolution can provide detailed information 

about ice dynamics and capture fine-scale variations. Additionally, given that ice 

primarily forms during the winter season, when clouds are abundant during the day, 

it becomes imperative for sensors to be capable of penetrating through cloud cover 

for effective ice cover assessment. 

Radars, specifically SARs, emerge as a favourable option due to their high spatial 

resolution, cloud independence, and ability to observe the Earth's surface day and 

night, making them an ideal remote sensing instrument for comprehensive ice 

monitoring from space. 

 

Figure V-5. Example of different types of sensors for ice cover monitoring. 
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Radar backscatter 

Radars emit a certain amount of energy 

towards the surface of the earth, and it 

reflects this energy, but only a part of the 

energy is scattered back and red by the 

radar antenna sensor. The strength of the 

reflected signal depends on the objects on 

the Earth's surface. Generally speaking, 

radar measures the roughness of a surface, 

the rougher it is, the greater the 

backscattered signal. 

The satellite image of the ice cover depends 

on its roughness, age, thickness, amount of 

air bubbles, and many other factors. When 

the surface of the ice cover is smooth or the 

ice is covered with water, then such a 

surface acts as a specular reflector, when 

the surface is rough (consisting of broken, 

deformed ice), the signal can be reflected in 

all directions (Figure V-6). 

 

 

 

Figure V-6. Example of backscatter. 
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Polarisation 

One important aspect of 

SAR is polarisation. 

Polarisation refers to the 

orientation of the electric 

field in the radar wave as it 

propagates. 

The backscattered signal 

contains information about 

the surface's response to all 

polarizations. 

However, SAR systems are 

designed with specific 

antennas that have fixed 

polarizations, and they can 

only measure the 

component of the 

backscattered signal that 

matches their own 

polarisation orientation. 

For instance, if a SAR  

Figure V-7. Three main types of polarizations used in SAR. 

 

sensor has an HH polarisation (horizontal transmit and receive), it can only measure 

the portion of the backscattered signal that corresponds to the horizontal 

polarisation. If the surface reflects the radar wave in a different polarisation (e.g., 

VV), the sensor won't be able to measure that part of the backscatter. 

Polarisation and ice: By changing the polarisation of the emitted and received 

signal, we can obtain different images that can provide different and complementary 

surface information. The interaction of the transmitted signal with the observed 

surface determines how bright it will be in the radar image in a specific polarisation. 

Below you can see examples of ice in different polarizations (Figure V-8). On the left, 

it is clear that the ice is much brighter in the same vertical polarisation (VV) image 

than in the VH polarizations. 

However, on the right, the difference between the HH and HV polarizations (when the 

horizontal polarisation signal is sent to the ground) is not so obvious, the contours 

of the ice can be clearly seen in both pictures. 
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Figure V-8. Ice in different polarizations. 

 

Preprocessing of SAR Images 

Preprocessing of remote sensing data plays a crucial role in ice 

cover detection from SAR images, ensuring data quality and 

consistency. The main preprocessing steps for ice cover detection 

include orbit correction, radiometric calibration, and terrain 

correction. 

All SAR image processing steps are thoroughly explained in 

Chapter 0. By following the described guidelines, you will obtain a 

refined final image free of geometric distortions and aligned with a 

standardised coordinate system. This final image will provide a 

clearer representation of the ice cover and its features. 

This way, ice cover detection from satellite images can be 

conducted with improved accuracy and reliability. It sets a solid 

foundation for subsequent analysis, classification, and 

interpretation of ice cover dynamics and variations over time. 
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Ice cover detection 

Various image interpretation techniques can be used to identify ice cover in remote 

sensing data. These techniques include: 

Visual interpretation 

The manual examination of satellite images to detect ice cover based on its 

visual characteristics by searching for recognizable features linked to ice, such 

as bright or white surfaces, which commonly signify the presence of ice. Ice 

patterns, such as sea ice and ice floes, can be observed to pinpoint regions 

with substantial ice extent. 

Image classification 

A computer-based technique that automatically categorises pixels or image 

segments into different classes, such as ice and non-ice. This process uses 

various algorithms to assign pixels to specific classes based on their spectral 

characteristics. 

Change detection 

Comparison of multiple satellite images acquired at different times to identify 

changes in ice cover extent and conditions. Pixel-based or object-based change 

detection methods can be used. Pixel-based methods compare individual pixels 

between two images to detect changes in spectral values, while object-based 

methods group neighbouring pixels with similar properties to detect changes 

in ice cover patterns, such as ice breakup or formation. 

By combining various image interpretation methods, analysts and researchers can 

obtain a more comprehensive grasp of ice cover extent, variations, and attributes in 

remote sensing data. 

Colour manipulation 

Colour manipulation of radar images is 

limited compared to optical imagery. 

SAR images are typically grayscale, 

representing radar backscatter 

intensity values, and do not have 

inherent colour information like RGB 

(Red, Green, Blue) images. However, 

SNAP software provides some basic 

colour manipulation options (Figure 

V-9) that can help enhance the 

visualisation of SAR images for better 

interpretation of the observed features, 

e.g., distinguishing ice cover or open 

water areas. 
 Figure V-9. Colour manipulation in SNAP. 
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After finishing the preprocessing of the SAR image, open one of the bands and in the 

lower left part of the SNAP window choose Color Manipulation. If you cannot see it, 

then in the upper menu bar select: View > Tool Windows > Color Manipulation. 

By sliding the triangles below the graph, you can adjust the contrast and brightness 

of your opened image. Play around with it to find the best way to enhance the 

visibility of specific features or details in the SAR image. 

 

 
Reset to defaults – restores the initial settings. 

 

Expand and shrink histogram horizontally – you can see either all 

histogram values or shrink the visualisation only to the defined range. 

The example below (Figure V-10) shows a Curonian Lagoon (triangle-shaped area, 

half-covered by ice) separated by a land barrier from the Baltic Sea (on the left). 

Underneath them, there are histograms that were applied to adjust the contrast and 

brightness of the image. Notice the position of the triangles at the bottom. 

 

Figure V-10. Example of colour manipulation for the Curonian Lagoon ice cover case. 

False colour composite: Utilise False Colour Composites: display SAR images in 

false colour composites using different polarisation combinations. This can enhance 

the visibility of specific features, such as open water (dark areas), ice cover (bright 

areas), and different ice types. 
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While SAR images are grayscale, you can create a false colour composite (Figure 

V-11) by combining different polarisation bands or images acquired at different 

times. A false colour composite assigns different bands to the red, green, and blue 

channels, creating a false-colour representation of the SAR data. This can help 

highlight specific features or changes in the image. Experimenting with different 

band combinations can help you obtain the most informative and visually appealing 

false colour representation of the radar data. 

SNAP offers band division, multiplication, and subtraction options, enabling the 

creation of false colour composites for radar images (Figure V-11, Figure V-12). These 

operations combine bands or polarisation channels in complex ways to emphasise 

specific characteristics of the observed area. 

 

Figure V-11. Example of false colour composite. 

To display your radar image in false 

colour composite using SNAP, after 

finishing the preprocessing steps 

right-click on your last layer in the 

Project Explorer window and 

choose Open RGB Image Window. 

In the pop-up window, you will see 

that for the Red and Green colours 

the bands are already selected, but 

for the Blue one, you select a 

combination of bands. Press the 

drop-down arrow near the Profile 

section and select one of the 

options suggested. Preferably, 

select the bands converted to 

decibels (dB). 
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Play around with different combinations to determine which one visualises the ice 

cover features best. 

 

Figure V-12. Examples of these false colour combinations. 

Ice floe or open water area estimation 

Computation of ice floe (Figure V-13, 

Figure V-14) or open water areas in the 

ice cover is possible using SNAP 

software. By drawing a polygon around 

your region of interest (ice or open 

water gap in it) you can calculate its 

corresponding real-world area. This 

feature is particularly useful for 

monitoring ice dynamics over time. 

For computing the region of interest’s 

(ROI) area, select the Polygon drawing 

tool and by left clicking go around the 

edges of ROI, and finish the polygon by 

double-clicking the left mouse button. 

After finishing drawing your polygon, in 

the upper menu bar select: Raster > 

Mask > Mask area. In the pop-up 

window see a line Mask area, which 

indicates the total area of your polygon. 
Figure V-13. Ice floe. 
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Figure V-14. Ice floe area estimation. 

 
Polygon mapping tool – can be found in the toolbar at the top of the 

SNAP window. 

The same procedure can be applied when measuring the open water area in the ice 

cover (Figure V-15): 

 

Figure V-15. Computation of open water area. 

Masking unwanted areas: Masking in satellite images is used to selectively filter 

out specific areas or features of the image, leaving only the regions of interest for 

further analysis or visualisation. It is a valuable technique in radar image analysis 

as it enables more focused and accurate interpretations of the data, contributing to 

improved insights of the area. 

In SNAP you can automatically apply a land or sea mask, i.e., remove all the land or 

water parts of the image. To achieve this, select: Raster > Mask > Land/Sea Mask. 

Since we are interested in water or ice surface, in the pop-up window under the 

Processing parameters tab, select an option to mask out the land of your image and 

press Run. As you see below (Figure V-16), ice floes in the resulting image appear 
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much brighter. This is due to the fact that we eliminated a lot of land pixels, which 

had high backscatter values. Now the grey colour scale represents a different range 

of pixel values. 

 

Figure V-16. Application of masks. 

To further improve the colouring of the image, we can remove the open water area 

next to our study focus. On the left of this example, there is a sea (light grey colour) 

where ice cover usually does not form, thus it’s mostly open water. 

We can remove it from the image by drawing a polygon around it (using the Polygon 

drawing tool) and in the upper menu bar selecting the same Land/Sea Mask option 

as we did when masking the land area, however in the pop-up window under the 

Processing parameters tab, select the Use Vector as Mask option and check the 

box near Invert Vector (Figure V-17). 

 

Figure V-17. Masking land area. 
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If we would not mark the inversion, then the resulting image would only show the 

sea area (Figure V-18). 

 

Figure V-18. Example of mask applications. 

Texture Analysis: Texture analysis (Figure V-19) focuses on quantifying spatial 

variations in pixel intensity values within the satellite image. For ice cover 

identification, texture analysis can highlight different ice types and conditions based 

on their surface roughness and structure. Common texture analysis methods include 

the Grey Level Co-occurrence Matrix. This tool can be found in SNAP software, in 

the upper menu bar selecting Raster > Image Analysis > Texture analysis > Grey 

Level Co-occurrence Matrix. 

 

Figure V-19. Example of texture analysis. 
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The most common texture features obtained from Grey Level Co-occurrence Matrix 

analysis (Figure V-20) include: 

 

The texture features are calculated for each pixel in the image and written into 

separate bands. The values in these bands represent the texture characteristics of 

each pixel in the original image. 

By investigating the textures of each of the produced layers derived with this tool, 

you can distinguish different characteristics of the ice surface (Figure V-21). 

Contrast  

 

 

Figure V-20. Using Grey Level Co-occurrence 
Matrix. 

Higher contrast values indicate 

greater variations between 

neighbouring pixel intensities, 

representing sharper texture 

boundaries. 

Dissimilarity 

Higher dissimilarity values indicate a 

greater dissimilarity or dissimilitude 

between adjacent pixel values, 

indicating more noticeable and 

pronounced differences in texture. 

Homogeneity 

Higher homogeneity values indicate 

more uniform textures. 

Energy 

Higher homogeneity values indicate 

more uniform textures. 

Entropy 

Higher homogeneity values indicate 

more uniform textures. 

Correlation 

Higher correlation values indicate 

more linearly related textures. 
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Figure V-21. Example of different ice characteristics. 

Time series analysis: Time series data is crucial for ice observations from satellite 

images because it offers a continuous and dynamic record of changes in ice 

conditions (e.g., extent, distribution, and characteristics) over time. Satellites provide 

frequent and regular image captures, allowing for the creation of a sequence of 

images representing the evolution of ice cover over various periods, from days to 

years.  

The high frequency of satellite images simplifies the analysis of ice temporal 

variability, enabling us to study ice cover dynamics, such as ice drift, fragmentation, 

and leads (openings in the ice), in detail.  By analysing these temporal changes, we 

can gain valuable insights into the behaviour of ice in response to seasonal and 

climatic variations. For instance, we can observe the expansion and retreat of ice 

cover during the annual freeze-up and melt seasons. 

Time series data not only allows tracking of these temporal variations (Figure V-22) 

but also understanding of long-term trends in ice behaviour. By examining changes 

in ice extent and concentration over several years or decades, we can detect patterns 

and anomalies that may be related to climate change. Monitoring these trends is vital 

for assessing the impacts of global warming and climate variability on the ice cover. 
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Figure V-22. Ice floes drifting from the southern part of the lagoon towards the northern. 

Tips & Tricks 
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VI.  Flood detection using remote sensing  
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The main tools to detect flood extent are water level measuring stations, satellite 

data, radars. The floods usually cover vast areas of land and are hardly accessible, 

which makes monitoring of flood extent difficult or near impossible without remote 

sensing techniques. In this case study we propose the method to detect flood over 

large area using ESA’s Synthetic Aperture Radar (SAR) Sentinel-1 sensor, which is 

used widely not only because it allows to monitor large areas but also because it is 

not influenced by cloud coverage as it penetrates through the atmospheric 

disturbances and allows to monitor evolution of the flood without disturbances. 

Product type: GRDH (Ground Range Detected High Resolution) 

Sensor mode: IW (Interferometric Width) 

Polarisation: VV+VH 

Date and time: 2022-02-27 16:20 

Name: S1A_IW_GRDH_1SDV_20220227T162021_20220227T162046_042101_050412_BC83 

Supplementary data entitled “mask_land.zip” can be found at: 

https://github.com/oxodron/Qredo/tree/main/Flood%20Detection 

Using these parameters, the image has spatial resolution of 20.3x22.6 m in size and 

pixel size converted to 10x10 m with every pixel value representing detected 

magnitude of surface reflectance (Figure VI-1). 

 

Figure VI-1. Parameters for Sentinel-1 download using ESA Copernicus Open Access Hub. 



106 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

106 

 

After downloading SAR file, open Snap. First step is to open product (more details 

how to do it - in Chapter 0), navigate to the folder where the data is downloaded and 

open all the downloaded .zip files. 

The opened file will appear in Product Explorer on the left of your screen if Snap is 

in default mode, then the file can be expanded and the file could be visualized as VV 

polarisation, you can find this using this path: File you added to Product Explorer 

> Bands > Amplitude_VV (Figure VI-2). 

 

Figure VI-2. Example of visualization. 

In this exercise we will perform most common pre-processing steps used for SAR 

image preparation using Graph Builder . 

These steps include Read > Subset > Apply-Orbit-File > ThermalNoiseRemoval > 

Calibration > Speckle-Filter > Terain-Correction > Write. 

When Graph Builder is opened, it has only 2 operators: Read and Write. 

The flood, in this case, is only expected in the river delta, so not all the image is 

needed. As we do not need whole area for analysis, we use Subset operator to crop 

image to the required extent. You have to right-click on the blank space in the Graph 

Builder (it is written: Right click here to add an operator) and go to Add > Raster > 

Subset.  

The next step is to add Apply-Orbit-File operator to Graph Builder. This step is 

needed because orbit state vectors, provided in the SAR metadata, are not accurate 

and, therefore, should be updated. Once again, right-click on the blank space in the 

Graph Builder and go to Add > Radar > Apply-Orbit-File. 

The next step is to add ThermalNoiseRemoval operator to Graph Builder. This step 

is needed because SAR emits Thermal Noise which hampers with SAR reflectivity 
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estimates. Right-click on the blank space in the Graph Builder and go to Add > 

Radar > Radiometric > ThermalNoiseRemoval. 

The next step is to add Calibration operator to Graph Builder. This step is needed 

because SAR does not include radiometric correction, thus this step is required for 

the pixel values to truly represent the radar backscatter of reflecting structure. Once 

again right-click on the blank space in the Graph Builder and go to Add > Radar > 

Radiometric > Calibration. 

The next step is to add Speckle-Filter operator to Graph Builder. This step is needed 

because SAR images has “salt and pepper” effect, called speckles, which is caused 

by random constructive and destructive interference. To do this right-click on the 

blank space in the Graph Builder and go to Add > Radar > Speckle Filtering > 

Speckle-Filter. 

The last operator to add to Graph Builder is Terrain-Correction operator. As you 

can see in main canvas, SAR image is upside down, it means that the image is still 

in radar geometry, and further some pixels can be distorted due to satellite tilt and 

topographical variations on the ground. Right-click on the blank space in the Graph 

Builder and go to Add > Radar > Geometric > Terrain Correction > Terrain-

Correction. 

This step requires to connect all the operators together if they appear in the Graph 

Builder canvas, in order as presented by the steps above. You can right-click on any 

of the operator and select Connect Graph, otherwise, this step can be done manually 

by dragging arrow, which appears next to operator box. Then you glide over it and 

drag to another operator (Figure VI-3).  

 

Figure VI-3. Example of using Graph Builder. 
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After we prepared Graph, we still need to set parameters for pre-processing. All of 

this can be done using Graph Builder. 

First, make sure that in Read operator the right Source Product is chosen. After that 

select Subset operator and tick these boxes: Copy Metadata and choose Subset 

image to Geographic Coordinates and you fill the box under the map with your 

desired coordinates and click Update (if you will use Subset in Menu Bar you have 

to fill following coordinates in Geo coordinates tab).  

North latitude bound: 55.6 

West longitude bound: 21.1 

South latitude bound: 54.9 

East longitude bound: 22.3 

POLYGON ((21.1 54.9, 22.3 54.9, 22.3 55.6, 21.1 55.6, 21.1 54.9)) 

 

Figure VI-4. Processing steps. 

 

 

 

NOTE: Graph Builder does not always work and might give the following error: Error: 

[NodeId: ThermalNoiseRemoval] java.lang.NullPointerException., if it is the case, then 

all of the steps must be produced manually and separately, one by one which can be 

done using all the same directories (except of Read and Write) in the Menu Bar: 
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In the Apply-Orbit-File operator (Figure VI-5) keep the default settings: 

 

Figure VI-5. Processing steps. 

In ThermalNoiseRemoval operator we make sure that Remove Thermal Noise box is 

ticked (it should be ticked by default) (Figure VI-6): 

 

Figure VI-6. Processing steps. 

In the Calibration operator we leave default settings (Figure VI-7): 

 

Figure VI-7. Processing steps. 

In the Speckle-Filter operator we use following parameters:  

Filter: Lee Sigma 

Window Size: 7x7 

Sigma: 0.9 

Target Window Size: 3x3 
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For the Terrain-Correction operator we keep the default Map Projection set as 

WGS84(DD). We will use SRTM 3Sec Digital Elevation Model. In this exercise we 

will untick the box Mask out areas without elevation (note: this could be used if 

there are no available permanent water body mask) as we have more accurate .shp 

file for excluding permanent water bodies “mask_land.shp”, which we will use in the 

GIS part of this exercise (Figure VI-8). 

 

Figure VI-8. Processing steps. 

In the Write operator we choose the Name of SAR product which will be saved and 

Save as: BEAM-DIMAP and choose a Directory to Save to. 

After all these parameters are ready, one can click Run (depending on the computer, 

it can take 1 to 5 minutes to process). 

The pre-processed file will appear in Product Explorer on the left of your screen if 

Snap is in default mode, then the file can be expanded and visualized as VV 

polarisation. One can find this using this path: “File you produced” in Product 

Explorer > Bands > Sigma0_VV. 

The water surface and land surface have different characteristics of surface 

roughness and those characteristics are quite recognisable using SAR imagery. 

After preparing the image for work we will choose the best threshold for separating 

water from land surface. This approach to map floods is called histogram 

thresholding. First, we look into Colour Manipulation tab and Switch the view of 

image to logarithmic display (Figure VI-9). 
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Figure VI-9. Colour manipulation steps. 

Water surface has a low signal return compared to land surface due to specular 

backscattering characteristics. Determination of the appropriate threshold will have 

the most influence for the end result. In the Figure VI-9 histogram (on the left bottom 

of the screen, if it is default view), we first switch to logarithmic display to see more 

comprehensible view. Two peaks can be seen: the first one is water surface (as 

mentioned above, water has lower signal return), the second one is land surface 

(which has higher signal return). In this case, the land surface seems to start from 

the values of 1.1E-2 which is equal to 0.01 (the value can be determined using sliders 

on the bottom of grayscale).  

In the next step we will use the threshold established using histogram to separate 

water from land surfaces in SAR image. For this step once again open Model Builder 

and click on the blank space in the Graph Builder, then right-click to Add > Raster 

> BandMaths. We should produce a short Graph, which consists of the following 

operators: Read > BandMaths > Write (Figure VI-10). 

 

Figure VI-10. Example of building a graph. 

This step requires to connect all the operators together if they appear in the Graph 

Builder canvas in order as presented by the steps above, as was explained before. 

In the Read operator, make sure you have chosen the newly produced product. It 

should be marked as [2] product before the name. In this case, we will leave default 

name of Target Band but one can choose any other, which fits better for the research 

purposes (Figure VI-11). The Band maths expression is the following:  

if Sigma0_VV < 0.01 and Sigma0_VV > 0 then 1 else 0. 
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Figure VI-11. Example of Band Maths. 

This expression will produce the binary layer where pixels with value of 1 represent 

water surface, and pixels with value of 0 represent land surface. This layer should 

appear on canvas. 

Now, open Write operator, choose the Name of a file (in our case we will leave it as 

default, choose directory. And most importantly, Save as: GeoTIFF (Figure VI-12). 

 

Figure VI-12. Processing steps. 
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After everything is ready, click Run and it will produce a binary GeoTIFF layer, which 

can be used in GIS. 

Now open QGIS and open raster produced using ESA Snap using Menu bar: Layer 

> Add Layer > Add Raster Layer… and add a shapefile which is in the 

supplementary material mask_land.shp using directory Layer > Add Layer > Add 

Vector Layer… 

After adding both layers to QGIS, open Processing Toolbox and find Clip Raster With 

Polygon tool. Use Raster produced with ESA Snap in the Input and mask_land in 

Polygons. Make sure that both layers are in the same projection (written in [] at the 

end of a layer Name, in this case it is [EPSG:4326]) (Figure VI-13). 

 

Figure VI-13. Example of clipping raster. 

After performing this step, you will get black and white layer with permanent water 

bodies clipped. To visualize the flood better, we need to change visualization, which 

can be done by right-clicking on layer, produced using Clip Raster With Polygon 

and clicking on Properties… Then click on Symbology and change Render type to 

Paletted/Unique values, then click on classify (Figure VI-14). 
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Figure VI-14. Visualization steps. 

And, before finishing, one can choose more representative colours by clicking on the 

color itself. Value “0” is land, and “1” is floodwater. After choosing the colours of your 

liking, click OK and in the end, you will have a map looking like that in the canvas 

of QGIS (Figure VI-15).  

 

Figure VI-15. Final flood map.  
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VII. Remote sensing of chlorophyll-a concentration mapping 
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From satellite observations in the optical part of the spectrum the concentrations of 

different constituents (pure water, chlorophyll, sediments, coloured dissolved organic 

matter) can be estimated. Chlorophyll concentration is one of the most important 

variables as it is an indicator of algal blooms. Phytoplankton blooms occur naturally 

in areas with high nutrient concentrations (coastal areas – nutrient runoff from land). 

When phytoplankton cells die, they sink to the seabed where they are decomposed 

by bacteria requiring oxygen. 

Case study: remote sensing of chlorophyll-a: The study area for this exercise 

will be the Curonian Lagoon (the Baltic Sea). Eutrophication, led by cyanobacteria 

blooms and hypoxia, have been increasingly observed in the Curonian Lagoon. 

Monitoring of the chlorophyll concentrations is important to investigate the spatio-

temporal changes of algal blooms, determine the water quality and evaluate if the 

overtaken measures (improvement of wastewater treatment plants) are effective to 

mitigate the pollution. 

Data used: one Sentinel-3A level 1 image acquired on 28 September 2020 

(S3A_OL_1_EFR____20200928T094012_20200928T094312_20200929T134412_01

79_063_193_1980_LN1_O_NT_002.SEN3). NOTE: the satellite image downloaded 

from the archive is zipped. Prior the exercise, the satellite image should be unzipped. 

Software in use: SNAP and QGIS 

Opening and exploring satellite data in SNAP: Open SNAP on the desktop. 

Click on the Open product icon (Figure VII-1) or go to File > Open Product and find 

the satellite image. Navigate to the folders of the extracted product, select 

xfdumanifest.xml file and Open to load the product to SNAP: 

 

Figure VII-1. Opening the product. 
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The opened products will appear at the Product Explorer tab in the upper left part of 

the window (Figure VII-2). 

 

Figure VII-2. Product Explorer view in SNAP. 

Right click on the Level-1 product name 

(S3A_OL_1_EFR____20200928T094012_20200928T094312_20200929T134412_01

79_063_193_1980_LN1_O_NT_002) and select Open RGB Image Window to create 

and visualize an RGB composition image. In a new window select Profile > OLCI L1 

- Tristimulus and click OK (Figure VII-3).  

 

Figure VII-3. Steps of image visualization. 
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The view of the image is very dark and for that reason it should be enhanced. Go to 

the Colour Manipulation tab in the lower left corner of the SNAP window. Here the 

histogram stretch for each of the RGB component bands can be changed (Figure 

VII-4 and Figure VII-5). 

 

Figure VII-4. Steps of colour manipulation. 

 

Figure VII-5. Steps of colour manipulation. 

Satellite data pre-processing in SNAP: Satellite images cover larger areas, 

contain a lot of information (therefore, their volume can vary from 300 MB to 1.5 GB) 

than is required for analysis, therefore, before further analysis, the satellite image 
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can be subsetted and only the area that will be needed in further steps can be left. 

Press the Right mouse button on the satellite image and select Spatial Subset from 

View (Figure VII-6). The subsetting can be performed by selecting the Region of 

interest or by selecting the Bands (Figure VII-7). 

 

Figure VII-6. Subsetting the image. 

 

Figure VII-7. Subsetting the image. 
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In the SNAP program a new product will appear that is virtual [2]. The new product 

can be saved on the computer. Right mouse click on [2] satellite image name, select 

Save Product > YES, shorten name to sensor, level of processing and date > 

Save, e.g., 20200928T094012_S3A_OL_1_EFR_Kursiu marios.dim. Right-click on 

this image and select Open RGB Image Window. In the new window that appears, 

select Profile: OLCI L1 - Tristimulus. Press OK. An RGB photo composite will open 

in a window. The cropped satellite image according to the selected parameters will 

appear (Figure VII-8). 

Figure VII-8. Processing steps. 

Secondly, the projection to the satellite image will be applied, and the spatial 

resolution will be unified: Select Raster > Geometric > Reprojection > specify the 

location on the computer where the new file will be saved > select the 

coordinate system (WGS 1984, Projection UTM Zone, specify the UTM zone 

(e.g., 34N), change the spatial resolution to 300x300 m > RUN (Figure VII-9). 

 

Figure VII-9. Steps of reprojecting the image. 
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Figure VII-10. Example of using Pin placing tool. 

The radiation registered by the optical sensor can be investigated. Select several 

places in the satellite image, this can be done using the Pin Placing tool function 

(Figure VII-11 and Figure VII-11). The Pin Manager can be prompted in the SNAP by 

navigating to View > Tool Windows > selecting Pin Manager. 

 

Figure VII-11. Example of using Pin placing tool. 

Select Optical > Spectrum View. This tool allows to visualize the signal registered 

by the optical sensor in different spectral bands (Figure VII-12). 
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Figure VII-12. Example of visualizing the signal. 

Satellite image processing in SNAP: The Case 2 Regional Coast Colour 

processor (C2RCC) had originally been developed by Doerffer and Schiller for the 

MERIS sensor, and then it was improved through the ESA DUE CoastColour project 

(Brockmann et al., 2016). It is applicable to all past and current ocean colour sensors 

(such as Sentinel-3) as well as Sentinel-2. It has been validated in various studies 

and is available through ESA’s Sentinel toolbox SNAP. It is also used in the Sentinel-

3 OLCI ground segment processor of ESA for the generation of the Case 2 water 

products. C2RCC will be used to reproduce the Level-2 Water product that contains 

chlorophyll-a concentration among other water quality parameters (total suspended 

matter, coloured dissolved organic matter, transparency etc.). 

In the toolbar, select Optical > Thematic Water Processing > C2CC Processors > 

OLCI (Figure VII-13). 

Figure VII-13. Processing steps. 



123 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

123 

 

The parameters used are listed below (Figure VII-14). For this exercise the default 

I/O Parameters will be left, the output product name and Folder will be indicated. 

Majority of Processing Parameters will be left as default. It is suggested to specify 

water temperature and salinity using in situ data, if exist, or can be adjusted 

according to common average values of the parameters. In case of the Curonian 

Lagoon, water salinity on the date of investigation was 2.9 PSU on average, water 

temperature - 17.0 °C. ‘Output AC reflectances as rrs instead of rhow’ was selected, 

as the major parameter of interest for further investigation is Remote Sensing 

Reflectance. After specifying the parameters, select RUN. the processing might take 

several minutes depending on the size of the satellite image. After the processing is 

completed, a new product [3] will be automatically opened in SNAP. 

 

Figure VII-14. Processing steps. 
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The layer containing chlorophyll-a concentration can be visualised: 

 

Figure VII-15. Visualization of Chl-a layer. 

The colour palette can be applied to the visualised layer: Colour Manipulator > 

Import colour palette from text file > cc_chl.cpd > NO 

 

Figure VII-16. Application of colour palette. 

The layer containing chlorophyll-a concentration (conc_chl) is virtual. It can be 

changed by right mouse click on the layer > Convert band and right click on the 

name of satellite image > Save Product. 
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Investigate how the atmospheric correction affected the reflected radiation recorded 

by the satellite sensor Optical > Spectrum View. 

 

Figure VII-17. Example of Spectrum view. 

Cloud masking in SNAP: The obtained result shows that clouds have a great 

impact on the quality and accuracy of satellite information, the presence of clouds 

results in artefacts - very high concentrations of chlorophyll-a, which are incorrect. 

In this case, cloud masking is an important step to leave pixels that are not affected 

by clouds. 

 

Figure VII-18. Example of cloud masking. 
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For this purpose, the C2RCC provides information layers that can be found at the 

Mask Manager, the Cloud_risk layer is used for cloud masking: 

 

Figure VII-19. Information in Mask Manager. 

The Cloud_risk information layer can be applied to the chlorophyll-a concentration 

layer, as a result of which the incorrect values will be changed to No Data. Right 

click on the layer conc_chl > Properties > Valid pixel expression > 

c2rcc_flags.Valid_PE&&!Cloud_risk > Close 

 

Figure VII-20. Processing steps. 
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The layer that will allow us to eliminate pixels that are significantly affected by clouds 

can be created: Raster > Band math > Name: let's create a layer name 

"Cloud_mask" > Uncheck Virtual Band > choose Edit Expression… > in the 

window specify "$2.conc_chl && ! $2.Cloud_risk” > OK > OK 

 

Figure VII-21. Application of Band Maths. 

The output: 

 

Figure VII-22. Output result. 

The created layer can be applied to the chlorophyll-a concentration layer, so the 

values near the clouds will be changed to No Data: Raster > Band math > Name: 

create a new layer name, e.g., Chl_final > uncheck the Virtual Band > Edit 

Expression… > indicate in the window $2.conc_chl * $2.Cloud_mask > OK > OK. 
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Figure VII-23. Editing Band Maths. 

The output: 

 

Figure VII-24. Output result. 

 

 

 



129 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

129 

 

Exporting the created chlorophyll-a concentration layer: File > Export > 

GeoTIFF > Subset... > Band subset > select only chl_final > NO (optional) > NO 

(optional). The name of the file can be changed.  

 

 

Figure VII-25. Exporting layer. 



130 

 

 

 Guide to Remote Sensing Applications for Aquatic Environment Monitoring 

 

130 

 

 

Figure VII-26. Exporting layer. 

According to the same procedure it is recommended to export as Geotiff file the 

created cloud mask layer. 

Data visualisation in QGIS: Open the exported GeoTIFF file in QGIS: QGIS > 

Layer > Add Layer > Add Raster Layer > select the exported file > apply the color 

palette (for more information on QGIS, see Chapter III) 

 

Figure VII-27. Data visualization. 
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Final notes: Atmospheric Correction is a crucial step for the chlorophyll-a 

concentration accuracy. Currently, there are various atmospheric correction 

algorithms: Acolite, iCOR, C2RCC and its variants for different optical sensors, 

POLYMER, MODTRAN4, 6SV etc. that can be applied prior to the retrieval of 

chlorophyll-a concentration. Therefore, before the further use, the chlorophyll-a 

concentrations obtained from satellite OLCI data after applying C2RCC processors 

should be validated with in situ chlorophyll-a concentration for the accuracy 

investigation. If the accuracy of data is nor satisfactory, other Atmospheric 

Correction, or chlorophyll-a concentration retrieval algorithm should be tested for 

the area of investigation. 

 

Figure VII-28. Comparison of the chlorophyll-a concentration in the Curonian Lagoon derived from OLCI 
data after application of C2RCC processor (C2RCC) and 6SV for Atmospheric Correction and band-ratio 

algorithm (Curonian Lagoon method) as described in Vaičiūtė et al., 2021. 
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VIII. Bathymetry and water transparency mapping  
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Bathymetry, the study of underwater depth of lake or ocean floors, is a crucial aspect 

of marine and limnological sciences. For many years, scientists and researchers have 

been leveraging modern technology to map the depths of water bodies. The advent of 

satellite remote sensing has revolutionized this field by providing an efficient, large-

scale, and cost-effective method to acquire bathymetric data. This guidebook chapter 

focuses on the utilization of satellite imagery for bathymetry acquisition with the 

exemplar case of Plateliai Lake, Lithuania from 02.05.2022. In situ depth data for 

validation is provided in the supplementary material under “Bathymetry” and can 

be found via this link: https://github.com/oxodron/Qredo. 

Case study: bathymetry acquisition: In this exercise, Sentinel-2 Level 2 data 

will be utilized, available for direct download from the Copernicus Hub. Level 2 data 

inherently contains atmospheric correction, making it a valuable resource for our 

study. However, in instances where only Level 1 data is accessible, supplementary 

instructions will be provided to elucidate the process of conducting manual 

atmospheric correction. This ensures the refinement of data quality and accuracy, 

indispensable for the success of our scientific exploration. 

Data used: S2A_MSIL2A_20220502T095031_N0400_R079_T34VEH_20220502T140620.zip 

Validation data and polygons: Qredo/Bathymetry at main oxodron/Qredo 

(github.com) 

Merging images: The first step in using satellite images for bathymetry involves 

merging multiple images to get a comprehensive and holistic view of the area of 

interest, in this case, Plateliai Lake in Lithuania. Depending on the area size and 

satellite's orbit, a single image might not capture the entire region of interest, so it's 

essential to merge multiple images. SNAP provides the perfect tool for this task, you 

can access it via Raster > Geometric > Multi-size mosaic. This process ensures 

that the resulting image is a geometrically coherent mosaic, essential for accurate 

georeferencing and subsequent analysis steps. 

 

Figure VIII-1. The process of merging satellite images to create a comprehensive and geometrically 
coherent mosaic. The mosaic enables accurate georeferencing and analysis of the water body. On the 

left is two images before merging and on the right) after merging to one. 

 

https://github.com/oxodron/Qredo
https://github.com/oxodron/Qredo/tree/main/Bathymetry
https://github.com/oxodron/Qredo/tree/main/Bathymetry
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Atmospheric correction.  

[Important note: if LVL2 data was downloaded directly, this step can be skipped.] 

Atmospheric correction is a crucial step in the process of using satellite images for 

bathymetry. When a satellite captures an image, the signals are susceptible to 

interference from the atmosphere, which can cause distortions such as scattering 

and absorption by atmospheric particles and gases. It's therefore vital to correct 

these distortions to obtain the true reflectance values of the target object on the 

ground — in our case, the water body.  

The most commonly used algorithm for this task is Sen2Cor, a plugin available 

within the Sentinel Application Platform (SNAP). In the event that the Sen2Cor plugin 

is not pre-installed, it can be seamlessly integrated using the ESA SNAP software. To 

initiate this, navigate to the menu bar, select Tools, then Plugins, followed by 

Available Plugins, and finally, choose Sentinel-2 SEN2COR Processor. Upon 

completing the installation and restarting the SNAP software, the plugin should be 

readily available, facilitating further progression of our scientific endeavour. 

SEN2COR can be accessed through the path Optical > Thematic Land Processing 

> Sen2Cor. The primary function of Sen2Cor is to provide scene classification, 

atmospheric correction, and cirrus correction for Sentinel-2 Level-1C products, 

which ultimately improves the accuracy and quality of the bathymetric data derived 

from these images. (Figure VIII-2). 

 

Figure VIII-2. Atmospheric correction using the Sen2Cor algorithm. This step is essential for mitigating 
distortions caused by atmospheric scattering and absorption, thereby refining the true reflectance values 

of the required waterbody. 

Clipping and Georeferencing: After atmospheric correction, the next step 

involves narrowing down the satellite imagery to only the region of interest, a process 

known as clipping or subsetting. For our case study, the area of interest is Plateliai 

Lake. This clipping process reduces computational demands and focuses the 

subsequent analyses on the area of importance. In SNAP, the tool used for this task 

can be accessed via Raster > Subset. 
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Within the Subset tool, there are options for both a Spatial Subset and a Band 

Subset. For the Spatial Subset, you should define the area encompassing Plateliai 

Lake, effectively creating a square that contains the entire lake and cuts out the 

surrounding areas. 

For the Band Subset, the selection of specific bands is critical as they relate to the 

light wavelengths most useful for bathymetry calculation. For Sentinel-2 images, the 

required bands for bathymetry include B2 (Blue), B3 (Green), B4 (Red), and B8 (Near-

Infrared). Each of these bands captures a different part of the electromagnetic 

spectrum, providing essential information for accurate depth calculation. 

Following subsetting, georeferencing is performed to ensure the spatial accuracy of 

the imagery. This process aligns the subset satellite images to a spatial grid, ensuring 

each pixel corresponds to a specific geographical location. This is an essential step 

to ensure that bathymetric data derived from satellite images align accurately with 

other geographic datasets. (Figure VIII-3). 

 

Figure VIII-3. Depicted is the process of clipping the satellite image, focusing solely on Plateliai Lake. 
This subset is further reduced in size by removing the bands that are not required for depth calculations. 

Land Masking: Land masking is the next critical step in the process of acquiring 

bathymetric data from satellite images. This process involves differentiating between 

the water body and the surrounding terrestrial areas within the satellite image. 

Ensuring that the subsequent bathymetric analyses are conducted only on the water 

body is crucial to avoiding any inaccuracies due to depth calculations made on land 

areas. 

One common and efficient method for performing land masking utilizes the Near-

Infrared (NIR) band (B8 in Sentinel-2 images). This band is particularly useful due 

to the spectral properties of water and land. While water bodies absorb most NIR 

light leading to low reflectance values, land areas reflect a higher amount of NIR light. 
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In this context, we employ a conditional rule for differentiating between water and 

land pixels (Figure VIII-4). If the NIR reflectance is greater than 0.05, it is classified 

as land and removed from the analysis. This is expressed through the statement "if 

B8 > 0.05 then NaN else 1". Any pixels with a B8 value exceeding 0.05 (indicative 

of land) are assigned a NaN (Not a Number) value, effectively masking them out, 

whereas water bodies (with reflectance values less or equal to 0.05) are assigned a 

value of 1. 

 

Figure VIII-4. The image demonstrates the application of land masking on Plateliai Lake using the Near-
Infrared (NIR) band. The operation classifies water and land pixels based on their NIR reflectance 

values, effectively isolating the water body for subsequent analysis. 

This operation is performed using the Band Maths tool in SNAP, which can be 

accessed via a right-click on the image. After applying this rule, only the water body, 

Plateliai Lake in our case, remains active for subsequent analysis, with all terrestrial 

areas effectively masked out (Figure VIII-5). We name the new calculated product 

“Masked_land”. After this step we apply “Masked_land” to each band using same 

Band Maths functions and name each band accordingly B2_land_masked, 

B3_land_masked, B4_land_masked, B8_land_masked.  

 

Figure VIII-5. Displayed is the "Masked_land" product and the corresponding land-masked bands. 

These bands—B2_land_masked, B3_land_masked, B4_land_masked, B8_land_masked—are prepared 
for further processing. 
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Sun Glint Correction: One of the challenges faced when using satellite images for 

bathymetry is the occurrence of sun glint. Sun glint is the reflection of sunlight off 

the water's surface, which can cause distortions in the satellite images and, in turn, 

affect the accuracy of water depth measurements. Therefore, an essential step in the 

process of bathymetric data acquisition from satellite images is sun glint correction. 

The formula used for sun glint correction, as proposed by Hedley et al. (2005), is as 

follows: R'i = Ri – bi * (RNIR – MinNIR). In this equation, R'i is the corrected 

reflectance, Ri is the original reflectance of the band, bi is the correction coefficient 

for each band, RNIR is the reflectance of the NIR band, and MinNIR is the minimum 

NIR reflectance value. For instance, when applying this formula to Band 2 (Blue) of 

a land-masked image, the formula becomes: R'i = B2_land_mask – 0.0043 * 

(B8_land_mask - 0.009). Note that 0.0043 is the correction coefficient for Band 2 and 

0.009 is the minimum NIR reflectance. 

This sun glint correction operation is repeated for each of the subset bands: B2 

(Blue), B3 (Green), and B4 (Red). Note that it isn't applied to the NIR band (B8) 

because it was used as a reference in the sun glint correction equation. We name 

each new band accordingly B2_glint_corrected, B3_glint_corrected, 

B4_glint_corrected. The result is an image with significantly reduced sun glint effect, 

making it much more suitable for subsequent bathymetric analysis (Figure VIII-6). 

 

Figure VIII-6. Sun glint correction process, employing Hedley et al.’s formula. The operation reduces the 

sun's reflective interference on the water surface, enhancing the accuracy of the bathymetric data. (left) 
each band after the sun glint correction and (right) the RGB composite from these bands. Squares in the 

lake represent polygons, found in course Github repository as shape file, for sampling of deep areas. 

Correction of Dark Atmospheric Objects: The next step in the process is the 

correction of dark atmospheric objects. Dark objects like shadows and some dark 

surfaces can interfere with the accuracy of water depth measurements in the satellite 
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images. Therefore, it is crucial to correct these effects to enhance the overall quality 

of bathymetric data. 

The procedure involves subtracting a specific value from the sun glint-corrected 

bands, with this value corresponding to the minimum reflectance value of a 

particular Region of Interest (ROI) within the image. The formula for the correction 

of dark objects would look like this: B2_glint_corrected - 0.005 for Band 2 (Blue) and 

B3_glint_corrected - 0.0095 for Band 3 (Green). The results are named accordingly: 

B2_dark_object_removed and B3_dark_object_removed. 

The values of 0.005 and 0.0095 are determined by the minimum reflectance value 

within the ROI (Region of interest). This region should ideally be selected in an area 

that is not affected by sun glint to avoid biasing the dark object correction with values 

skewed by glint effects (Figure VIII-7). By doing this, you ensure that the correction 

value is representative of the minimum reflectance values caused by dark 

atmospheric objects rather than reflective interference. After this step, the satellite 

image is much better prepared for accurate bathymetric analysis. 

 

Figure VIII-7. This image represents the correction of dark atmospheric objects within the image, 
removing their interference with the water depth measurements. This step increases the overall quality 

of the derived bathymetric data. 
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Empirical Application of Bathymetry: In this step all the previous corrections 

and adjustments culminate in the conversion of satellite-derived data into water 

depth information, forming the bathymetric map. 

According to the methodology proposed by Stumpf et al. in 2003, the bathymetric 

calculation can be achieved by correlating water depth with the ratio of green and 

blue wavelengths' reflectance. This method is based on the observation that different 

wavelengths of light penetrate water bodies to different depths. Blue light can 

penetrate deeper into the water than green light (Figure VIII-8). 

The formula for this calculation in band maths window is: log(1000 * 

B3_dark_object_removed) / log(1000 * B2_dark_object_removed). The output of this 

calculation is a numerical representation of water depth across Plateliai Lake. It's 

important to note that this empirical model should ideally be calibrated with in situ 

measurements to validate and increase the accuracy of the depth estimations. Once 

the bathymetry calculation is completed, you will have a bathymetric map of the lake 

ready for further studies or applications. 

 

Figure VIII-8.The final image showcases the application of empirical bathymetry, converting the 
corrected and adjusted satellite-derived data into a numerical representation of water depth across 

Plateliai Lake. 

Validation: The final stage in the process of bathymetric data acquisition involves 

the validation and calibration of the computed bathymetry with in situ 

measurements. This step is vital for assessing the accuracy of the bathymetric model 

derived from satellite images and making any necessary adjustments to improve its 

reliability. 
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To execute this, you will need to import in situ depth points, typically provided in the 

form of a vector file, such as an ESRI Shapefile, into SNAP. These files contain precise 

depth measurements at specific points in the lake, taken directly on-site. 

Once the in situ depth points are loaded into SNAP, you can proceed to draw a 

correlation graph between these points and the computed bathymetry. This can be 

done using the Correlative Plot tool within SNAP. By comparing the two datasets, you 

can gauge the accuracy of your bathymetric model. Discrepancies between the model 

and the in situ data can indicate areas where the model may need to be calibrated or 

refined. 

 

Figure VIII-9. Bathymetric map of Plateliai Lake, derived from satellite imagery and validated against 
in situ measurements. This map provides a spatially accurate depiction of underwater topography, 
serving as a critical resource for scientific studies and applications in marine ecology and limnology. 

This iterative process of comparison and adjustment ensures the final bathymetric 

model is as accurate and reliable as possible, thereby enhancing the utility of the 

derived depth data for further studies or applications on Plateliai Lake. 
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IX. Ship detection using remote sensing  
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Marine traffic surveillance can be performed using different technologies. Usually 

ships identify their position using cooperatives systems, such as Automatic 

Identification System (AIS), Long Range Identification and Tracking (LRIT) and Vessel 

Monitoring System (VMS). In case ships are not identifiable using cooperative 

systems (e.g., due to illegal fishing) other means to control ship traffic can be used, 

such as remote sensing techniques as SAR. It is a quite reliable tool to monitor ships 

as any of the man-made structure in the water can be detect as it emits high 

backscatter values, meanwhile, the water surface has low backscatter values. 

Case study: ship detection. In this exercise we will use Sentinel-1 Level-1 image 

which has the following parameters: 

Product type: GRDH (Ground Range Detected High Resolution) 

Sensor mode: IW (Interferometric Width) 

Polarisation: VV+VH 

Date and time: 2021-07-22 04:51 

Name: 

S1B_IW_GRDH_1SDV_20210722T045103_20210722T045128_027902_035453_2

D5A  

Supplementary data entitled “LT_1km.zip” can be found at: 

https://github.com/oxodron/Qredo/tree/main/Ship%20detection 

Using these parameters, the image has a spatial resolution of 20.3x22.6 m in size 

and pixel size converted to 10x10 m with every pixel value representing the detected 

magnitude of backscatter from the Earth’s surface. 

After downloading SAR file, open Snap. The first step is to open the product. Navigate 

to the folder where the data is downloaded and open all the downloaded .zip files. 

The opened file will appear in Product Explorer on the left of your screen if Snap is 

in default mode, then the file can be expanded and visualized as VV polarisation.  

One can find it using this path: “File you added” to Product Explorer > Bands > 

Amplitude_VV. 

In this scenario, we are only interested in ships around the entrance of Klaipeda 

Seaport, so not all the image is needed. As we do not need the whole area for analysis, 

we use Subset to crop the image to the required extent. You have to click on the 

Raster menu in Menu Bar at the top and choose Subset.  

First, choose to Subset image to the Geographic Coordinates tab (it can be found in 

the Spatial Subset tab), fill in the coordinates of the Subset and click OK (Figure 

IX-1). In this case, we will use the following coordinates:  

North latitude bound: 55.80 

West longitude bound: 21.20 

South longitude bound: 55.60 

East longitude bound: 20.60 
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Figure IX-1. Specifying Product Subset. 

The next step is to add Apply-Orbit-File. This step is needed because orbit state 

vectors, provided in the SAR metadata, are not accurate and should be updated. 

Mark the subset that was just produced, go to the menu bar and choose Radar > 

Apply-Orbit-File (Figure IX-2). 

 

Figure IX-2. Application of Orbit file. 

In the Apply-Orbit-File we keep the default settings and save as BEAM-DIMAP, then 

click Run. Now you can open an image which was just produced. It should be marked 

with a number [3] at the beginning of an image. To open an image and expand the 

file go to Bands > Amplitude_VV and double click on it. The image should be still in 

radar geometry. 
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In next part, we will eliminate artificial objects on ground and only artificial objects 

left should be ships, by using shapefile. There are other options how to eliminate 

land, such as using Land-Sea-Mask in Ocean Object Detection. If you want to do 

this, skip this part. 

In the next step we will import a shapefile of a Lithuanian cost with 1 kilometre 

expanding into the sea. We will use a file named LT_1km.shp in the supplementary 

material. To import a shapefile, click on subset, which was recently produced and 

should be marked with a number [3]. Then go to the Menu bar, choose Vector > 

Import > ESRI file and locate LT_1km.shp file (Figure IX-3). 

 

Figure IX-3. Importing shape file. 

The shapefile should appear on canvas on SAR image as shown in Figure IX-4. 

 

Figure IX-4. Example of imported shape file. 
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Now we will do a part, where we detect objects in the Sea, we need to locate it in 

menu tab Radar > SAR Applications > Ocean Applications > Ocean Object 

Detection (Figure IX-5). 

 

Figure IX-5. Object detection steps. 

In the first tab called Read of the Ocean Object Detection operator, make sure, that 

the chosen image is the last one produced. It should be marked with [3] (Figure IX-6). 

 

Figure IX-6. Object detection steps. 

In the second tab called Land-Sea-Mask, we choose to Use Vector as Mask. The 

choice must be LT_1km, then mark Invert Vector and as we already have a shapefile 

with extended shoreline, we fill Extend shoreline by [pixels] to 0. Otherwise, you 

can choose to Use SRTM 3sec, choose to Mask out the Land and then Extend 

shoreline by [pixels]: at least 100 pixels as 1pixel size is 10 m (Figure IX-7). 
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Figure IX-7. Object detection steps. 

Then go to Object-Discrimination tab where the Minimum and Maximum Target Size 

can be changed. It means that objects, that are smaller than Minimum Target Size 

will not be detected and larger than Maximum Target Size objects will not be detected 

(in this case we keep the default settings) (Figure IX-8). 

 

Figure IX-8. Object detection steps 

Lastly, go to Write tab and make sure it is saved as BEAM-DIMAP. After that click 

Run. 
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In this exercise we still need to perform one step as our image is still not Terrain 

corrected and is in radar projection. We locate Menu tab and go to this directory: 

Radar > Geometric > Terrain Correction > Range-Doppler Terrain Correction. 

 

Figure IX-9. Steps of terrain correction. 

After opening Range Doppler Terrain Correction operator in I/O Parameters tab we 

make sure that we chose the right Source Product (it should be the last one produced 

with number [4] at the front), we choose to Save as: GeoTIFF (Figure IX-10). 

 

Figure IX-10. Steps of range Doppler terrain correction 

Then click on Processing Parameters tab where you have to untick Mask out areas 

without elevation to not lose any information. Leave everything else in default and 

click Run (Figure IX-11). 
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Figure IX-11. Steps of range Doppler terrain correction 

Now we open QGIS and import the layer we just produced into canvas. To do so, go 

to Layer > Add Layer > Add Delimited Text Layer…(Figure IX-12). 

 

Figure IX-12. Importing layer in QGIS. 
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When opened, click on 3 dots located next to the File name  and locate 

ShipDetections.csv it should be located in:  

*your_saving_directory*\subset_0_of_S1B_IW_GRDH_1SDV_20210722T045103_20

210722T045128_027902_035453_2D5A_Orb_Cal_THR_SHP.data\vector_data\Ship

Detections.csv (Figure IX-13). 

 

Figure IX-13. Example of locating the file. 

After locating ShipDetections.csv, tick the box Custom delimiters in the File 

Format. After ticking the box, the additional boxes will appear. Untick other boxes 

and only tick Tab box. In Geometry Definition tab tick Point coordinates box and 

choose X field as field_6, Y field as field_5. Make sure that Geometry CRS is in 

EPSG:4326 – WGS 84. After everything is ready, click Add (Figure IX-14). 

 

Figure IX-14. Ship detection steps. 
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Now, we can add Open Street Map in QGIS in the Menu go to Web > Map Library > 

Map, expand Topography and Roads and select OpenStreetMap to visualize 

positions of the ships. In the Figure IX-15 the map with ships detected is presented. 

 

Figure IX-15. Map with the detected ships. 
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